# Contents

1. **Introduction** .......................................................................................................................... 1
   1.1 GiD-CCFD .......................................................................................................................... 1
   1.2 Using this Manual ................................................................................................................. 1

2. **Starting and Quitting GiD-CCFD** ......................................................................................... 2
   2.1 Starting GiD-CCFD ............................................................................................................. 2
   2.2 Saving a GiD-CCFD Project ............................................................................................. 3
   2.3 Quitting GiD-CCFD ........................................................................................................... 3

3. **CFD Analysis using GiD-CCFD** ......................................................................................... 4
   3.1 Outline of the Exercise ......................................................................................................... 4
   3.2 Creating Geometry ............................................................................................................. 4
      3.2.1 Creating Points and Lines ......................................................................................... 4
      3.2.2 Adjusting the Display ............................................................................................... 5
      3.2.3 Creating Lines ........................................................................................................... 5
      3.2.4 Displaying Labels ...................................................................................................... 6
      3.2.5 Zoom Display ........................................................................................................... 7
      3.2.6 Generating Surfaces ............................................................................................... 8
      3.2.7 Generating Volumes ............................................................................................... 9
   3.3 Setting Analysis Conditions .............................................................................................. 10
      3.3.1 Setting Analysis Type ............................................................................................. 10
      3.3.2 Setting Analysis Control Data .............................................................................. 11
      3.3.3 Defining Material Data .......................................................................................... 11
      3.3.4 Defining Conditions ............................................................................................... 12
      3.3.5 Setting Interval Data ............................................................................................. 13
      3.3.6 Setting Initial Data ................................................................................................. 14
   3.4 Meshing Generation ............................................................................................................ 15
      3.4.1 Setting Meshing Element Type ............................................................................... 15
      3.4.2 Setting Number of Meshing Partitions .................................................................. 15
      3.4.3 Meshing Generation ............................................................................................... 16
   3.5 Saving Files ........................................................................................................................ 18
   3.6 Executing Analysis ............................................................................................................. 18
      3.6.1 Analysis .................................................................................................................... 18
      3.6.2 Displaying Pictures ............................................................................................... 20

4. **Free surface flow analysis** ................................................................................................. 23
   4.1 Outline of the Exercise ......................................................................................................... 23
   4.2 Reading a GiD project .......................................................................................................... 23
   4.3 Setting Analysis Conditions .............................................................................................. 24
      4.3.1 Setting Analysis Type ............................................................................................. 24
      4.3.2 Defining Material Data .......................................................................................... 25
      4.3.3 Setting Initial Conditions ....................................................................................... 26
      4.3.4 Defining Boundary Conditions ............................................................................... 27
      4.3.5 Setting Interval Data ............................................................................................. 29
   4.4 Meshing Generation ............................................................................................................ 31
   4.5 Executing Analysis ............................................................................................................. 31
   4.6 Postprocessing .................................................................................................................... 31

5. **GiD-CCFD Analysis Interface** ......................................................................................... 33
   5.1 Problem data (analysis data) .............................................................................................. 33
   5.2 Initial Conditions ................................................................................................................ 40
      5.2.1 Assigning initial conditions .................................................................................... 40
   5.3 Materials ............................................................................................................................ 43
      5.3.1 Defining Materials ................................................................................................. 43
      5.3.2 Assigning Material ............................................................................................... 44
   5.4 Boundary Conditions ......................................................................................................... 47
      5.4.1 Assign (assigning boundary conditions) ............................................................... 47
      5.4.2 Draw (displaying boundary conditions) ............................................................... 49
      5.4.3 Unassign (canceling boundary condition settings) ............................................. 53
   5.5 Interval Data ....................................................................................................................... 54

6. **How to use User Defined Function** ................................................................................. 57
   6.1 Outline ................................................................................................................................. 57
      6.1.1 Limitation .................................................................................................................. 57
      6.1.2 Requirement .............................................................................................................. 57
<table>
<thead>
<tr>
<th>Section</th>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.2</td>
<td>Specifying User Defined Function</td>
<td>57</td>
</tr>
<tr>
<td>6.2.1</td>
<td>Boundary Conditions</td>
<td>57</td>
</tr>
<tr>
<td>6.2.2</td>
<td>Material data</td>
<td>58</td>
</tr>
<tr>
<td>6.3</td>
<td>How to build Dynamic Link Library</td>
<td>58</td>
</tr>
<tr>
<td>6.3.1</td>
<td>Preparation</td>
<td>58</td>
</tr>
<tr>
<td>6.3.2</td>
<td>Making source file (UserPlugin.cpp)</td>
<td>59</td>
</tr>
<tr>
<td>6.3.3</td>
<td>Building Dynamic Link Library</td>
<td>60</td>
</tr>
<tr>
<td>6.3.4</td>
<td>Summary of “Get Functions”</td>
<td>61</td>
</tr>
<tr>
<td>7.</td>
<td>Data File Format</td>
<td>64</td>
</tr>
<tr>
<td>7.1</td>
<td>List of Files Used</td>
<td>64</td>
</tr>
<tr>
<td>7.2</td>
<td>File Formats</td>
<td>64</td>
</tr>
<tr>
<td>7.2.1</td>
<td>Init.dat</td>
<td>64</td>
</tr>
<tr>
<td>7.2.2</td>
<td>Input.ini</td>
<td>65</td>
</tr>
<tr>
<td>7.2.3</td>
<td>Node.dat</td>
<td>66</td>
</tr>
<tr>
<td>7.2.4</td>
<td>Elem.dat</td>
<td>66</td>
</tr>
<tr>
<td>7.2.5</td>
<td>Bound.dat</td>
<td>67</td>
</tr>
<tr>
<td>7.2.6</td>
<td>Result, Result#.out</td>
<td>70</td>
</tr>
</tbody>
</table>
1. Introduction

1.1 GiD-CCFD

A GiD is an interactive graphic user interface for defining, preparing, and displaying all data related to numerical simulations. Shapes, materials, conditions, solution methods, and definitions of other parameters are included in the data. This interface generates meshing used for finite elements, finite volumes, or finite difference analyses. The GiD can also write data in formats required by numerical simulation programs. Numerical simulations can be executed and analysis results displayed from within the GiD.

The GiD-CCFD is customized with more additional functions than the GiD for use with thermohydrodynamic analysis software CCFD. Therefore, it can create computational models of CCFD and plot analysis results (post processing).

The flow of an analysis using the GiD-CCFD is shown below.

- Create geometry or input from CAD data
- Specify analysis control data for CCFD
- Create material data
- Create boundary conditions for geometry
- Set meshing size to geometry
- Create meshing
- Create boundary conditions for meshing (option)
- Execute analysis using the CCFD (use separate CCFD)
- Plot CCFD results

1.2 Using this Manual

This manual should be used when using the GiD-CCFD for the first time, and it is written to allow the basic usage methods of the GiD and CCFD to be learned through exercises.

This manual is divided into four sections.

Section 1 describes **starting and closing the GiD-CCFD**. This section describes starting projects, saving projects, and quitting the GiD-CCFD.

Section 2 describes **CFD analysis using the GiD-CCFD**. This section teaches methods to define shapes (geometry) and analysis data as well as methods to create meshing through exercises. Executing an analysis and post processing are also introduced.

Section 3 provides a reference for the **Data menu of the GiD-CCFD**, as well as a command reference for the GiD-CCFD analysis interface.

Section 4 provides a reference for the **data file format of the GiD-CCFD**, as well as the formats of data files used with the GiD-CCFD.
2. Starting and Quitting GiD-CCFD

2.1 Starting GiD-CCFD

Start the GiD-CCFD from the Taskbar by selecting GiD 7.2 on the Start > Program > GiD 7.2 menu.

To create a new model after starting the GiD-CCFD, begin the operation with the program as-is at startup. To read a model created beforehand, select the Open command from the Files menu.

The Read Project dialog box will be displayed. Select the folder where the GiD Project file is located (".gid" will be appended to the folder name and should be visible as one file in the Read Project dialog box) and click OK.
2.2 Saving a GiD-CCFD Project

GiD-CCFD data is divided into multiple files in one project. Saving a project saves all files (shapes, conditions, materials, meshing, etc) related to that project to disk.

Select the Files > Save command. The Save Project dialog box will display. In order to save a project, the GiD creates a directory to which the extension ".gid" is appended to the name. Depending on the files, all information is written to that directory and the GiD-CCFD can handle the directory of this project as a file.

The user must enter the ".gid" extension. The extension is automatically added to the directory name.

CAUTION: You must be careful with files when manually changing a Project.gid directory. When this is done, there is a danger that several pieces of information might be destroyed.

2.3 Quitting GiD-CCFD

Select the Files > Quit command to quit the GiD.

If the most recent data has not been saved, a confirmation dialog box will display asking whether you want to save the data before quitting the program. To save, select “Yes.” Select “No” if don’t want to save. Select Cancel to return to the program.
3. CFD Analysis using GiD-CCFD

Here, creating computational models of pre-processing, CFD analysis, and post-processing using the GiD-CCFD can be briefly experienced through exercises.

3.1 Outline of the Exercise

Turbulent flow step flow (a regular two-dimensional turbulence problem) \( h = 3.81 \), x-direction fixed flow velocity (air) 18.2 m/s

3.2 Creating Geometry

First creating and working with a geometry entity in the GiD will be introduced.

Open the GiD and start program operations. A new GiD program will be automatically created.

Let’s create a geometry entity from this new GiD program.

3.2.1 Creating Points and Lines

To begin, we will determine a start point (point 1) and an end point (point 2) and then create a straight line. The coordinates are 0,0,0 and 80.01, 0,0, respectively.

To create a point, simply use an Auxiliary Window to enter the coordinates of the desired point location. This is done by opening the Coordinates Window dialog box the following order:

Utilities / Graphical / Coordinates Window.

Next, select Geometry / Create / Point from the Top Menu. The mouse cursor will change from an arrow to a cross.

Take the following step in the already opened Coordinates Window dialog box.

In the same manner, enter the coordinates in the Coordinates Window to create the following points.

Point 2: Coordinates (80.01, 0, 0)
Point 3: Coordinates (80.01, 7.62, 0)
Point 4: Coordinates (0, 7.62, 0)
Point 5: Coordinates (-15.24, 7.62, 0)
Point 6: Coordinates (-15.24, 0, 0)
Point 7: Coordinates (0, -3.81, 0)
Point 8: Coordinates (80.01, -3.81, 0)

To complete point creation, in the same manner as other commands, either press the Escape button on the keyboard or click the center mouse button. The mouse cursor will return to an arrow from the cross shape. Select Close to close the Coordinates Window.

3.2.2 Adjusting the Display
Select the following command to allow all created points to be displayed within the range of the screen.
View → Zoom → Frame

3.2.3 Creating Lines
Here we will combine two points to create a line. Advance from the Top Menu and select the following.
Geometry → Create → Line
You can also use the option in the Toolbar shown below.

Next, we will determine the start point of the line. In order to select the points already created on the screen, click the right mouse button to open the Mouse Menu and select Contextual → Join C-a.

Note: Using Join you can select the points already created on the screen. The No Join command allows you to create new points with the same coordinates as the points selected on the screen. The cursor shape is different for Join and No Join.
Select point 1 as the first point and point 2 as the second point and then determine the line according to these.

To continuously create a line that continues from the beginning and end, continuously specifying a second point will continuously generate the line. In this manner, create each line shown below.

Line 2: Point 2 – Point 3
Line 3: Point 3 – Point 4
Line 4: Point 4 – Point 1

Click the **Escape key** when you want to change the start point of the line.

Line 5: Point 4 – Point 5
Line 6: Point 5 – Point 1
Line 7: Point 6 – Point 1
Line 8: Point 1 – Point 7
Line 9: Point 7 – Point 8
Line 10: Point 8 – Point 2

After all lines are created, click the **Escape key** twice to complete line creation.

### 3.2.4 Displaying Labels

Select the following command to display all created points and line labels.

**View ➔ Label ➔ All**
3.2.5  Zoom Display

Select the following command to zoom the display of one portion of a model.

**View → Zoom → In**

This will change the cursor to a thin black cross. Specify the display range you want to zoom. First, click the mouse once to specify the start point of the display range you want to zoom. Then, move the mouse to determine the display range you want to zoom. Clicking the mouse once at a suitable area will confirm the display range you want to zoom, and then zoom the display.

A screen with a zoomed display is shown below.
3.2.6 Generating Surfaces

Display the entire model using the method described above, namely, View → Zoom → Frame from the Top Menu.

Next, generate a surface as shown below.
Select the following from the Top Menu.

Geometry → Create → NURBS surface → By contour

Sequentially select line 1 – line 2 – line 3 – line 4. If you click the Esc key and complete specifying the lines, a surface will be generated. Clicking the Esc key once again will complete the surface generation. In the same manner, generate a surface of line 4 – line 5 – line 6 – line 7 and line 1 – line 8 – line 9 – line 10.

Select the following command to display all created points and lines as well as surface labels.

View → Label → All

The points and their labels will be displayed in black, the lines and their labels will be displayed in blue, and surfaces and their labels will be displayed in pink.
3.2.7 Generating Volumes
Generate volumes as shown below. Select the following from the Top Menu. Utilities → Copy

For Entities type select Surfaces using the geometry type selection targeted for copying. Transformation should be Translation. Also enter coordinates of SecondPoint to determine the thickness in the z-axis direction.

Do extrude should be Volumes. Next, click Select and select surface 1, surface 2, and surface 3 and then press the Esc key (or click Finish). This will copy the surfaces and generate volume 1, volume 2, and volume 3.
3.3 Setting Analysis Conditions

3.3.1 Setting Analysis Type

Specify FINAS as the solver used for the analysis and select the analysis type (static stress analysis, condition analysis, dynamic analysis, CFD analysis). This allows you to set analysis conditions which correspond to the predetermined analysis type of FINAS.

Because CFD analysis is selected here, select the following from the Top Menu.

Data ➔ Problem Type ➔ FINAS ➔ CFD

The following warning screen will appear. Namely, if the solver used for the analysis or the analysis type changes after setting the analysis conditions, the analysis conditions will be lost. Please use caution. Click OK. This will change the pull-down menu of the Data menu of the Top Menu to the menu for CFD analysis of FINAS.

3.3.2 Setting Analysis Control Data

Set analysis control data. Select the following from the Top Menu.

Data ➔ Problem Data

The Problem Data dialog box shown below will display.

As an example, enter “STEP FLOW ANALYSIS” as a title for the analysis problem in the TITLE input field. For the Type of problem select STEADY and for the Turb model select ke (k-ε). For the Sweep select 100.
When you finish entering the data, click **Accept data** to validate the data. Click the **Close** button to close the dialog box.

### 3.3.3 Defining Material Data

Select the following from the **Top Menu**.

**Data > Materials**

The **material** dialog box shown below will display.

Next, Select AIR for **Materials**. Click the **Assign** button to select **Volumes**.

Select volume 1, volume 2, and volume 3. After the selection, click the **Esc key** to complete the volume selection. Click the **Esc key** once again, or click the **Close** button to close the dialog box.
### 3.3.4 Defining Conditions

Select the following from the **Top Menu**.

- **Data**\textcolor{red}{\rightarrow}**conditions**\textcolor{red}{\rightarrow}**boundary**

The **boundary** dialog box shown below will display.

Select FIXED-VELOCITY and set the values for X-Value, Y-Value, and Z-Value to 0. Next, click the **Assign** button and select surfaces 6, 8, 10, 11, and 12. After the making the selection, click the **Esc key** to complete the surface selection.

Next, set the value of the X-Value of FIXED-VELOCITY to 18.2 and in the same manner as before select surface 9 to complete the surface selection. Thereafter, select FIXED-PRESSURE and set the value of PRESSURE to 0. Click the **Assign** button and select surface 5. After the making the selection, click the **Esc key** to complete the surface selection.

Click the **Esc key** once again or click the **Close** button to close the dialog box.
3.3.5 Setting Interval Data

Select the following from the Top Menu.

Data ➤ Interval

The Interval dialog box shown below will display.

The STEP input field is where you enter the number of steps.
Lastly, click the Accept data button to make the defined step data valid. Click the Close button to complete the Interval dialog box.

3.3.6 Setting Initial Data

Select the following from the Top Menu.

**Data** ➔ **Conditions** ➔ **Initial**

The Initial dialog box shown below will display.

The **STEP** input field is where you enter the number of steps.
Here we use default values for this problem. Click the Assign button, and select volume 1, 2 and 3. Lastly push Esc key to finish volume selection.

### 3.4 Meshing Generation

#### 3.4.1 Setting Meshing Element Type
Select the following from the Top Menu.

*Meshing* → *Element type* → *Hexahedra*

#### 3.4.2 Setting Number of Meshing Partitions
Select the following from the Top Menu.

*Meshing* → *Structured* → *Volumes*
Select volume 1, volume 2, and volume 3.
If you click the Esc key to complete the volume selection after the selection, the Enter value window dialog box shown below will display. Enter 21 for the number of partitions on line 11, and click the OK button to select line 11. All lines are selected in the same manner as line 11. After the selection, click the Esc key to complete the line selection. In the same manner, set 16 partitions for line 14, four partitions for line 17, eight partitions for line 18, and one partition for line 27. Click the Esc key or click the OK button to close the dialog box.

![Enter value window dialog box](image)

### 3.4.3 Meshing Generation

Select the following from the Top Menu.

**Meshing ➔ Generate**

The Enter value window dialog box shown below will display. Use the default value for the element size and click OK. A square shaped meshing will be automatically generated when this is done.
When the meshing generation is complete, the following message will display. Verify and then click **OK**.

Generated meshing will display as shown below. Analysis conditions are converted to finite elements and articulation points. When analysis conditions are modified after meshing generation, the meshing must be generated again.
3.5 Saving Files

Select the following from the Top Menu.

Files ➔ save as ...

The Save Project dialog box will display. In order to save a project, the GiD creates a directory to which the extension ".gid" is appended in the name. The directory of this project can be handled as a file by the GiD-CCFD.

The user is not required to enter the ".gid" extension. The extension is automatically added to the directory name.

If you enter "Sample" and click Save, a Sample.gid directory will be created in the specified directory.

3.6 Executing Analysis

3.6.1 Analysis

Select the following from the Top Menu.

Calculate ➔ Calculate window ...
The **process window** dialog box shown below will display. Click **Start** here. When clicked, CCFD data will be created and the analysis executed by CCFD.

![Process window](image)

In addition, if you select the following from the **Top Menu**, CCFD data will be created immediately and the analysis executed by CCFD.

**Calculate** ➔ **Calculate**

If CCFD data is successfully generated with GiD, following window will be appear. If there is no problem in descriptions in following window, click “Exit” button. Then CCFD starts calculation. If some error messages appear in the window, check your input data again.
When the analysis is complete, the **process info** dialog box shown below will display.

Click **Postprocess**.

The input files **fvm_ke_out.inp**, **fvm_out.inp**, **Result**, **temp_out.inp**, and **Sample.post.res** will be created in the **Sample.gid** directory. When these files are not created, you can assume some sort of error occurred. For this case, **output.out** created in the directory is useful for investigating the cause of the error.

### 3.6.2 Displaying Pictures

Select the following from the **Top Menu**.

**View Results** ➔ **Contour Fill** ➔ **Ep**

The Ep picture shown below will display on the screen.
Select the following from the Top Menu.

View Results → Contour Fill → $k$-$\varepsilon$

A distribution obtained by a $k$-$\varepsilon$ fill on the figure shown below will display.

Select the following from the Top Menu.

View Results → Contour Fill → Pressure

The distribution obtained by a Pressure fill on the figure shown below will display.
4. Free surface flow analysis
Here, creating computational models of pre-processing, CFD analysis, and post-processing for free surface flow analysis using the GiD-CCFD can be briefly experienced through exercises.

4.1 Outline of the Exercise
The backstep flow model created in the chapter 3 will be used. Here, it is assumed that flow is two dimensional, unsteady and inlet velocity is 1.0 m/s along x-direction.

4.2 Reading a GiD project
Start the GiD. And open the project of the backstep flow model created in the chapter 3, or the example project (backstep.gid). Then save the project in another name (ex. backstep_vof.gid). After saving project, select the following from the Top Menu in order to initialize analysis conditions.

Data → Problem type → CFD

Then, select the following from the Top Menu.
Utility → Move…

For Entities type select Volumes and for Transformation select Scale. For Scale factors enter 0.01.

Then click Select button and select volume 1, volume 2, and volume 3. After the selection, click the Esc key to complete the volume selection. Click the Esc key once again, or click the Close button to close the dialog box.
4.3 Setting Analysis Conditions

4.3.1 Setting Analysis Type

Set analysis control data. Select the following from the Top Menu.

Data → Problem Data

The Problem Data dialog box shown below will display.

As an example, enter “backstep_vof” as a title for the analysis problem in the TITLE input field. For the Type of problem select UNSTEADY and for the Turb model select NO(laminar flow). For the Sweep select 30. For the Relax factor enter 0.7. For the Relax factor P enter 0.3.

Next, select the Scalar tab and select “TEMPERA” and “Scalar2” check box.
Next, select the VOF tab. The conditions for free surface flow problems and material properties of the 2nd phase can be defined in this tab. Select “Use VOF” check box.

When you finish entering the data, click Accept data to validate the data. Click the Close button to close the dialog box.

### 4.3.2 Defining Material Data

Select the following from the Top Menu.

Data ➔ Materials
The **material** dialog box shown below will display.

Next, Select **WATER** for **Materials**. Click the **Assign** button to select **Volumes**.

Select volume 1, volume 2, and volume 3. After the selection, click the **Esc key** to complete the volume selection. Click the **Esc key** once again, or click the **Close** button to close the dialog box.

The material properties defined here are treated as the properties for the 1st phase.

### 4.3.3 Setting Initial Conditions

Select the following from the **Top Menu**.

Data → Conditions → Initial

The **Initial** dialog box shown below will display.
Select volume 1, volume 2, and volume 3. After the selection, click the Esc key to complete the volume selection. Click the Esc key once again, or click the Close button to close the dialog box.

4.3.4 Defining Boundary Conditions

Select the following from the Top Menu.

Data → conditions → Boundary

The Boundary dialog box shown below will display.
Select FIXED-VELOCITY and set the values for X-Value, Y-Value, and Z-Value to 0. Next, click the Assign button and select surfaces 6, 8, 10, 11, and 12. After the making the selection, click the Esc key to complete the surface selection. Next, set the value of the X-Value of FIXED-VELOCITY to 1.0 and in the same manner as before select surface 9 to complete the surface selection.

Thereafter, select FIXED-PRESSURE and set the value of PRESSURE to 0. Click the Assign button and select surface 5 and 13. After the making the selection, click the Esc key to complete the surface selection.
select FIXED-SCALAR2 and set the value of FIXED-SCALAR2 to 1. Click the **Assign** button and select surface 9. After the making the selection, click the **Esc** key to complete the surface selection.

Click the **Esc** key once again or click the **Close** button to close the dialog box.

**4.3.5 Setting Interval Data**

Select the following from the **Top Menu**.

**Data → Interval**

The **Interval** dialog box shown below will display.
For the Number of Steps enter 100. For the Time Step increment enter 0.01. For the Step freq. post process enter 5.

Next, select Gravity tab. In this tab magnitude and direction vector of the gravity acceleration can be specified. Enter values as following figure.

Lastly, select Criterion temp tab and enter 1 to Criterion temp.
After the setting interval data, click the Accept data button to make the defined step data valid. Click the Close button to complete the Interval dialog box.

4.4 Meshing Generation

Select the following from the Top Menu.
Meshing→Structured→Volumes
Select volume 1, volume 2, and volume 3.

Enter 40 for the number of partitions on line 11, and click the OK button to select line 11. All lines are selected in the same manner as line 11. After the selection, click the Esc key to complete the line selection. In the same manner, set 8 partitions for line 17. Click the Esc key or click the OK button to close the dialog box.

Then, select the following from the Top Menu.

Meshing→Generate
The Enter value window dialog box shown below will display. Use the default value for the element size and click OK. A square shaped meshing will be automatically generated when this is done.

With regard to details of meshing generation, refer to the section 3.4.3.

4.5 Executing Analysis

Select the following from the Top Menu and click start button.
Calculate→Calculate window ...

With regard to details of executing analysis, refer to the section 3.6.

4.6 Postprocessing

After the analysis is complete, enter the GID postprocess mode. To enter the GID postprocess mode by GID menu, select the following from the Top Menu.
Files → Postprocess

To display a distribution of volume fraction, Select the following from the Top Menu.
View Results→Contour Fill→Scalar2
A volume fraction distribution shown below will display.
5. GiD-CCFD Analysis Interface

Depending on the analysis type, all data handled in the Data menu in the GiD changes in correspondence to all the different analysis types. This allows you to select the installed analysis types. When selecting a new analysis type, already selected or defined material and condition information as well as other data parameters will be lost.

The Data menu in the GiD and CCFD interface is described below.

Select the following from the Top Menu.
Data→Problem type→FINAS→CFD

5.1 Problem data (analysis data)

Problem data is related to all data that are the basic items of an analysis. This is not related to shape elements. This data can also be entered before or after meshing generation.

Select the following from the Top Menu.
Data→Problem data

The Problem data dialog box will display. Input for the Problem data dialog box is accepted by pressing the Accept button to initially accept the data.

---

**TITLE**: Allows you to set a title for the current analysis case. The character string is a maximum of 80 alphanumeric characters.

**Type of problem**: Analysis type 1. Specify time management here. Select either STEADY, UNSTEADY or EXPLICIT.

**Turb model**: Analysis type 2. Selects turbulent model. You can select the turbulent models shown below.
- **NO**: Laminar model
- **k-ε**: Standard k-ε model
- **LES**: LES model

**Sweep**: Specifies the number of sweeps. The meaning differs depending on the model specified in Type of problem.
- **STEADY**: Specifies the total number of sweeps until the analysis completes.
- **UNSTEADY**: Specifies the number of sweeps during one time step.
- **EXPLICIT**: It is not necessary to set it.

**Relax factor**: Sets the relax factor. The meaning differs depending on the model specified in Type of problem.
- **STEADY** or **UNSTEADY**: Setting this value to a suitable value allows you to control excessive variations in variables. Variables become more difficult to vary as the value becomes smaller.
- **EXPLICIT**: It is not necessary to set it.

**Relax factor P**: Sets the relax factor for pressure or Courant number.
- **STEADY** or **UNSTEADY**: Setting this value to a suitable value allows you to control excessive variations in pressure. Pressure becomes more difficult to vary as the value becomes smaller.
- **EXPLICIT**: Means Courant number. Setting smaller Courant number increases numerical stability and calculation time.

**Scheme[0 1]**: Sets the windward coefficient. When set to 0, it is first order upwind difference and when set to 1, it is a second order central difference. If you set the value from 0 to 1, they will form a mixture. (Refer to Theory Manual 3.3.2.)
**Restart:***  Specifies an analysis using a restart. Selecting this check box allows you to restart from a specified file.

**Restart File:**  Specifies the input file name for the restart. Valid when the Restart check box is selected.
**Monitoring Point**: Specifies the cell number for monitoring point display. The values of each variable at points specified by monitoring points are displayed on the screen in order to know the convergence state during calculations.
TEMPERA:  Specifies temperature calculations. Selecting this check box will perform temperature calculations.

Scalar2:  Specifies calculations of scalar data 2. Selecting this check box will perform calculations of scalar data 2.

Scalar3:  Specifies calculations of scalar data 3. Selecting this check box will perform calculations of scalar data 3.

Scalar4:  Specifies calculations of scalar data 4. Selecting this check box will perform calculations of scalar data 4.

Scalar5:  Specifies calculations of scalar data 5. Selecting this check box will perform calculations of scalar data 5.
Use VOF: Specifies an analysis using VOF method. Selecting this check box allows you to use VOF method for free surface flow.

Number of phase: Specifies the number of phases. In the current version the number of phases is fixed at 2.

Courant number: Specifies Courant number for conservation equation of volume fraction.

Phase2 VISCOSITY: Specifies viscosity of secondary phase.

Phase2 THERMAL DIFF COEFF: Specifies thermal diffusion of secondary phase.

Phase2 DENSITY: Specifies density of secondary phase.

Phase2 EXCO: Specifies thermal expansion rate of secondary phase.
Use Coupling: Specifies an analysis coupling with PFC3D. Selecting this check box allows you to execute CFD-DEM coupling analysis.

Time Table: Specifies time for coupling problem.
- start: start time of coupling.
- end: end time of coupling
- step: time step interval of data exchange between CCFD and PFC3D.
5.2 Initial Conditions

Sets initial conditions during CFD analysis in Initial dialog.

Select the following from the Top Menu.

Data ➔ Conditions ➔ Initial

**Initial Value [Pres]:** Enter the initial value for the pressure of the calculation area.

**Initial Value [Vx]:** Enter the initial value for velocity in X-direction of the calculation area.

**Initial Value [Vy]:** Enter the initial value for velocity in Y-direction of the calculation area.

**Initial Value [Vz]:** Enter the initial value for velocity in Z-direction of the calculation area.

**Initial Value [Temp]:** Enter the initial value for the temperature of the calculation area when performing temperature calculations. This value is ignored when temperature calculations are not performed.

**Initial Value [Ke]:** Enter the initial value for turbulent energy of the calculation area when using k-ε model in the turbulent model. This value is ignored when turbulent flow calculations are not performed.

**Initial Value [Ep]:** Enter the initial value for viscous dissipation of the calculation area when using k-ε model in turbulent model. This value is ignored when turbulent flow calculations are not performed.

**Initial Value [Scalar2-5]:** Enter the initial value for Scalar 2-5 of the calculation area when performing scalar calculations. This value is ignored when scalar calculations are not performed.

### 5.2.1 Assigning initial conditions

**Assign:** Assigns initial conditions. If you press the Assign button, a selection list of geometry to which initial conditions are assigned will appear. Select the geometry you want to assign to assign the initial conditions.
**Entities**: Displays the list of the assigned initial conditions.

**Draw**: Displays the assigned initial conditions. If you press the Draw button, two lists will appear.
- All initial displays all initial conditions
- (Condition name) displays name of conditions which is selected by list box.
- Colors divides the initial conditions selected in the list box into colors and then displays them.
- Field’s value displays the value of the initial conditions.
- Field’s color divides the initial conditions by selected item then displays them.

**Unassign**: Cancels a material. If you press the Unassign button, three lists will appear.
- Initial-value Entities: If you press the Entities list, a selection list of geometry to cancel will appear. Select the geometry you want to cancel to cancel the initial conditions.
- All Initial-value: Cancels all initial conditions which is selected by list box.
- All Initial: Cancels all initial conditions.
- All Conditions: Cancels all initial and boundary conditions.
5.3 Materials

Sets material data for the analysis area. The Conditions that can be set are both shapes and meshing. We recommend setting to shape however. If set to shape, the material data automatically be reflected in the meshing. When set to meshing, the material data will be lost by regeneration of meshing.

Caution: If meshing is already generated, the meshing must be generated again for all changes to the set material, or material settings must be applied directly to the meshing.

Select the following from the Top Menu.

Data ➔ Materials

![](image)

5.3.1 Defining Materials

Material list

Select materials already defined from the list box. Materials not listed in this list box can be defined using the new material button.

New material data

You can create new material data using this button. Newly created material data is copied with the same structure as the material selected immediately before.

Delete material data

You can delete the currently displayed material data using this button.

Update material data

The currently displayed material data is reflected in the project using this button.
Enter physical property values for the following four items.

**DENSITY**: Enter the material density.

**VISCOITY**: Enter the viscosity coefficient of a material.

**THERMAL DIFF COEF**: Enter the thermal diffusion coefficient.

**EXCO**: Enter the thermal expansion rate.

### 5.3.2 Assigning Material

**Assign**: Assigns materials. If you press the Assign button, a selection list of geometry to which materials are assigned will appear. Select the geometry you want to assign to assign the materials.
**Draw:** Displays the assigned materials. If you press the Draw button, two lists will appear.

- This material displays the currently selected material.
- All material displays all materials.

**Unassign:** Cancels a material. If you press the Unassign button, three lists will appear.

- Entities: If you press the Entities list, a selection list of geometry to cancel will appear. Select the geometry you want to cancel to cancel the material.
- All material name: Cancels all materials of a material name.
- All Materials: Cancels all materials.
**Import/Export**: Reads / writes material data. If you press the Import/Export button, a selection dialog box of material database files will appear. Specify the material database file. The file extension is `.mat`.

When a file is specified, the Import/Export screen will appear. The column on the right is material data existing in a material database file, and the left side is material data that can be used at present. Clicking the material name and pressing the arrow allows you to copy from the material database file to the current data or from the current data to the material database file. You can also copy all the data by pressing the arrow twice.
5.4 Boundary Conditions

Sets boundary conditions during CFD analysis in Conditions.

Conditions can be set to both shapes and meshing although we recommend setting to shapes. When set to shapes, the displacement boundary conditions will be reflected in the meshing. When set to meshing, the displacement boundary conditions will be lost during meshing regeneration.

Caution: When meshing has already been generated, the meshing must be generated once again in order to move the new conditions to the meshing when changing the condition settings. If the meshing is not regenerated, a warning will sound when executing the analysis.

Select the following from the Top Menu.

Data→Conditions→Boundary

Use the buttons to select boundary conditions given to surfaces or volumes, respectively.

5.4.1 Assign (assigning boundary conditions)

The assign button assigns established boundary conditions to geometry or meshing. First, select the boundary conditions you want to assign from the list box, and then specify geometry or meshing after entering a numeric value corresponding to each. The following boundary conditions can be set from the list box for surfaces or volumes.

(a) Boundary conditions set to surface

- FIXED-VELOCITY: Sets the flow rate. Enter each component of the X, Y, and Z direction in each X-Value, Y-Value, Z-Value. Surfaces without a flow rate specified for the boundary condition are handled as symmetrical barriers.
- FIXED-PRESSURE: Sets the pressure. Enter the pressure to be set in PRESSURE.
- FIXED-TEMPERATURE: Sets the temperature. Enter the temperature to be set in TEMPERATURE.
  1. HEAT-FLUX: Sets the heat flux. Enter the heat flux to be set in HEAT-FLUX.
HEAT-TRANSFER: Sets the heat transfer coefficient and fixes the temperature. Set the heat transfer coefficient in COEFFICIENT and the temperature in TEMPERATURE.

FIXED-SCALAR2: Set scalar data 2 as a fixed value. Enter the value to be set in FIXED-SCALAR2.

SC2-FLUX: Sets the flux of scalar data 2. Enter the flux to be set in SC2-FLUX.

SC2-TRANSFER: Enter the transfer coefficient of scalar data 2. Enter the transfer coefficient in COEFFICIENT and the value of scalar data 2 in SC2-TRANSFER.

FIXED-SCALAR3: Sets scalar data 3 as a fixed value. Enter the value to be set in FIXED-SCALAR3.

SC3-FLUX: Sets the flux of scalar data 3. Enter the flux to be set in SC3-FLUX.

SC3-TRANSFER: Enter the transfer coefficient of scalar data 3. Enter the transfer coefficient in COEFFICIENT and the value of scalar data 3 in SC3-TRANSFER.

FIXED-SCALAR4: Sets scalar data 4 as a fixed value. Enter the value to be set in FIXED-SCALAR4.

SC4-FLUX: Sets the flux of scalar data 4. Enter the flux to be set in SC4-FLUX.

SC4-TRANSFER: Enter the transfer coefficient of scalar data 4. Enter the transfer coefficient in COEFFICIENT and the value of scalar data 4 in SC4-TRANSFER.

FIXED-SCALAR5: Sets scalar data 5 as a fixed value. Enter the value to be set in FIXED-SCALAR5.

SC5-FLUX: Sets the flux of scalar data 5. Enter the flux to be set in SC5-FLUX.

SC5-TRANSFER: Enter the transfer coefficient of scalar data 5. Enter the transfer coefficient in COEFFICIENT and the value of scalar data 5 in SC5-TRANSFER.

(b) Boundary conditions set to volume

SOLID: Specifies solid portions. Enter the velocity in FIXED VELOCITY.

HEAT-SOURCE: Sets calorific value. Enter the calorific value in HEAT SOURCE.

SC2-SOURCE: Sets the source of scalar data 2. Enter the generated amount in SC2 SOURCE.

SC3-SOURCE: Sets the source of scalar data 3. Enter the generated amount in SC3 SOURCE.

SC4-SOURCE: Sets the source of scalar data 4. Enter the generated amount in SC4 SOURCE.

SC5-SOURCE: Sets the source of scalar data 5. Enter the generated amount in SC5 SOURCE.

When setting conditions, all figure relationship functions (zoom, rotate, etc) can be used. To apply the settings, press the Esc key or click the Finish button in the Conditions screen.

Caution: When meshing has already been generated, the meshing must be generated once again to reflect any changes in the condition settings.
5.4.2  **Draw (displaying boundary conditions)**
Displays boundary conditions set to geometry or meshing. Five menus will appear when the Draw button is pressed.

- This (condition name) displays the boundary conditions selected in the list box (condition name).
- Colors divides the boundary conditions selected in the list box into colors and then displays them.
• All Conditions has another three sub-menus.
  Exclude local axes: Displays boundary conditions except for the boundary conditions set to local axes when using local axes.
  Only local axes: Displays only the boundary conditions set to local axes when using local axes.
  Include local axes: Displays boundary conditions including the boundary conditions set to local axes when using normal boundary conditions and local axes.
- Field's value displays the values of the boundary conditions selected in the list box. The sub-menu where you select the value to be displayed in response to the boundary condition will appear. For example, the three sub-menus for the values shown below will appear for FIXED-VELOCITY and the values of the boundary conditions in the X, Y, and Z directions will display.
  X-Value
  Y-Value
  Z-Value

For FIXED PRESSURE however, the sub-menu will only be PRESSURE.
• Field's color divides the values of the boundary conditions selected in the list box into colors and displays them. The sub-menu where you select the value to be displayed in response to the boundary condition will appear. For example, the three sub-menus for the values shown below will appear for FIXED VELOCITY and the values of the boundary conditions in the X, Y, and Z directions will be divided into colors and display.
  X-Value
  Y-Value
  Z-Value
For FIXED PRESSURE however, the sub-menu will only be PRESSURE.
5.4.3 Unassign (canceling boundary condition settings)

Cancels set boundary conditions. Three menus will appear when the Draw button is pressed.

- (condition name) Entities: Cancels the boundary conditions selected in the list box (condition name) by selecting geometry or meshing.

- All (condition name): Cancels the boundary conditions selected in the list box (condition name) for all geometry or meshing set by these boundary conditions.

- All Conditions: Cancels all boundary conditions.
5.5 Interval Data

Edits interval data. Use Data→ Interval Data.

This data can also be entered before or after meshing generation.

Select the following from the Top Menu.

Data→ Interval Data

The sub-menu shown below will appear.

 ![Interval Data Sub-menu](image)

**Number of Steps**: Enter the number of calculation steps for unsteady calculations. Enter 1 for steady calculations.

**Time step increment**: Enter the time step for unsteady calculations. The time step multiplied by the number of calculation steps will be the total calculation time. Enter 1 for steady calculations.

**Step freq. Post process**: Specify the file output interval of calculation results during unsteady calculations. If 1, it outputs files every step. If 10, it outputs files every 10 steps.
Gravity Value: Enter a value for gravity acceleration. Enter the direction of acceleration as a vector component in X, Y, Z below.

Gravity X direction: Enter X-direction component of gravity acceleration.

Gravity Y direction: Enter Y-direction component of gravity acceleration.

Gravity Z direction: Enter Z-direction component of gravity acceleration.
**Criterion temp**: Enter thermal expansion reference temperature when performing temperature calculations (Boussinesq approximation). Use for buoyancy calculations. This value is ignored when temperature calculations are not performed.
6. How to use User Defined Function

6.1 Outline
Here, how to define User Defined Functions for boundary conditions and material properties is explained. Using the User Defined Function, it is available to use temperature dependent material data, time dependent inlet velocity, etc. User Defined Function must be written in C++.

6.1.1 Limitation
User Defined Function is available for boundary conditions (section 6.5) and material properties (section 6.4).

6.1.2 Requirement
For creating original User Defined Function or modifying existing User Defined Function, the following development environment must be required.

Microsoft Visual C++.NET 2003 or higher （Standard or higher）

6.2 Specifying User Defined Function

6.2.1 Boundary Conditions
Select the following from the Top Menu.

Data→conditions→boundary
The Boundary dialog box shown below will display. Select boundary condition name from list box and enter the name of User Defined Function to setting column. In the following example, X-Value of FIXED-VELOCITY is set to User Defined Function named as “userX”.

Then click the Assign button to assign the boundary conditions to the geometry or meshing.
6.2.2 Material data

Select the following from the Top Menu.

Data → Materials

The Materials dialog box shown below will display. Enter the name of User Defined Function to setting column. In the following example, THERMAL DIFF COEF is set to User Defined Function named as "userT".

Then click the Assign button to assign the boundary conditions to the geometry or meshing.

6.3 How to build Dynamic Link Library

6.3.1 Preparation

If you create new User Defined Functions, you must prepare development environment for building User Defined Functions.

A template of User Defined Function is stored in the directory as follows.

C:\Program Files\GiD [Ver.No.]\Problemtypes\CFD.gid\UserPlugin (Ver.No] means GiD version number.)

Copy the directory shown above to working directory. In the example shown in below, a template directory is copied to "finas_cfd_test.gid" directory.
6.3.2 Making source file (UserPlugin.cpp)

UserPlugin.cpp (template of User Defined Function source file) is stored in the source directory “src” under the UserPlugin directory. User Defined Functions must be described in UserPlugin.cpp.

Start Microsoft Visual Studio and open the solution file (UserPlugin.sln) stored in the UserPlugin directory. Once the solution file is opened, open UserPlugin.cpp. Contents of UserPlugin.cpp is as follows.

```cpp
//-------------------------------------------------------
//        CFDPlugin.h: CFDPlugin クラスのインターフェイス
//-------------------------------------------------------
#include <windows.h>
#include <cmath>
#include "CFDPlugin.h"
#include "getData.h"
#define DLL_BOUND_DATA( func_name )
    extern "C" double __declspec(dllexport) ・・・・

using namespace CRC_CFD;

// ユーザー定義関数の設定
// サンプル-発熱量
DLL_BOUND_DATA( userSource )
{
    // This part must not be modified.
    User Defined Function must be defined here.
}
```

User Defined Function must be defined within parentheses below a header DLL_BOUND_DATA( … ). And you need to write a name of User Defined Function inside parentheses. In the list shown above, the name of User Defined Function is defined as “userSource”.

The list shown below is an example of User Defined Function. This User Defined Function gives heat source depending on coordinates of each cell center.

Variables defined in CCFD (ex. cell center coordinate, velocity, pressure, etc.) are available to use in User Defined Functions. You need to call “Get Functions” to get variables in CCFD. Summary of the Get Functions is shown in the section 6.3.4.

In the list shown below, function named as userSource call  data.GetCellCenter(iCell,si,sj,sk) to get coordinates of cell center. If data.GetCellCenter(iCell,si,sj,sk) is called, x, y and z coordinate of the cell center are stored to si, sj and sk respectively. Then heat source is evaluate using si, sj, sk.
DLL_BOUND_DATA( userSource )
{
    double si,sj,sk;
    double Source;
    double r1,r2;

    //Cell中心座標の取得
    data.GetCellCenter(iCell,si,sj,sk);

    r1 = 1.0 - sqrt(pow((si-2.0),2)+pow((sj-0.0),2));
    r2 = 1.0 - sqrt(pow((si-8.0),2)+pow((sj-0.0),2));
    if(r1>=0){
        Source = r1*1000.0;
    }else if(r2>=0){
        Source = r2*1000.0;
    }else{
        Source = 0.0;
    }
    return ( Source );
}

6.3.3 Building Dynamic Link Library

Select the following from the Top Menu of Visual Studio.

Build → Build UserPlugin

Once build process complete, UserPlugin.dll will be created in the GiD project directory.
### 6.3.4 Summary of “Get Functions”

#### Geometry

<table>
<thead>
<tr>
<th>name</th>
<th>argument</th>
<th>function</th>
<th>return values</th>
</tr>
</thead>
<tbody>
<tr>
<td>GetSurfaceCenter</td>
<td>const int iCell</td>
<td>Get coordinates of the center of the cell surface</td>
<td>Sx : x coordinate of the center of the cell surface</td>
</tr>
<tr>
<td></td>
<td>const int iSurf</td>
<td></td>
<td>Sy : y coordinate of the center of the cell surface</td>
</tr>
<tr>
<td></td>
<td>double &amp;Sx</td>
<td></td>
<td>Sz : z coordinate of the center of the cell surface</td>
</tr>
<tr>
<td></td>
<td>double &amp;Sy</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>double &amp;Sz</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GetSurfaceArea</td>
<td>const int iCell</td>
<td>Get area of the cell surface</td>
<td>Area : Area of the cell surface</td>
</tr>
<tr>
<td></td>
<td>const int iSurf</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>double &amp;Area</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GetCellVolume</td>
<td>const int iCell</td>
<td>Get the cell volume</td>
<td>Volume : cell volume</td>
</tr>
<tr>
<td></td>
<td>double &amp;Volume</td>
<td></td>
<td></td>
</tr>
<tr>
<td>GetCellCenter</td>
<td>const int iCell</td>
<td>Get coordinates of the center of the cell</td>
<td>Cx : x coordinate of the cell center</td>
</tr>
<tr>
<td></td>
<td>double &amp;Cx</td>
<td></td>
<td>Cy : x coordinate of the cell center</td>
</tr>
<tr>
<td></td>
<td>double &amp;Cy</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>double &amp;Cz</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Diagram of a cell surface (4 surfaces in tetrahedra)](image)

Center of the cell surface
### Analysis data

<table>
<thead>
<tr>
<th>name</th>
<th>argument</th>
<th>function</th>
<th>return values</th>
</tr>
</thead>
<tbody>
<tr>
<td>getTime</td>
<td>none</td>
<td>Get simulation time.</td>
<td>Retum value : time</td>
</tr>
<tr>
<td>GetScalar</td>
<td>const int iCell, const int iSurf, int ScalarType, double &amp;Scalar</td>
<td>Get scalar value.</td>
<td>Scalar : Scalar value(^1)</td>
</tr>
<tr>
<td>GetScalarSolid</td>
<td>const int iCell, const int iSurf, int ScalarType, double &amp;Scalar</td>
<td>Get scalar value in solid cell.</td>
<td>Scalar : Scalar value(^1)</td>
</tr>
<tr>
<td>GetKe</td>
<td>const int iCell, const int iSurf, double &amp;Ke</td>
<td>Get turbulent kinetic energy.</td>
<td>Ke : turbulent kinetic energy</td>
</tr>
<tr>
<td>GetEp</td>
<td>const int iCell, const int iSurf, double &amp;Ep</td>
<td>Get dispersion rate.</td>
<td>Ep : dispersion rate</td>
</tr>
<tr>
<td>GetPorosity</td>
<td>const int iCell, const int iSurf, double &amp;Porosity</td>
<td>Get porosity.</td>
<td>Porosity : Porosity</td>
</tr>
</tbody>
</table>

If fluid cell is connected to solid cell:
- GetScalar(iCell, iSurf, ScalarType, Scalar)
  → Scalar value at the fluid cell (Point A) is stored in “Scalar”
- GetScalarSolid(iCell, iSurf, ScalarType, Scalar)
  → Scalar value at the solid cell (Point B) is stored in “Scalar”

\(^1\) ScalarType=0 : Temperature, ScalarType=1~4 : Scalar2~5
### Material data

<table>
<thead>
<tr>
<th>name</th>
<th>argument</th>
<th>function</th>
<th>return values</th>
</tr>
</thead>
<tbody>
<tr>
<td>GetViscosity</td>
<td>const int iCell const int iSurf double &amp;Viscosity</td>
<td>Get viscosity.</td>
<td>Viscosity : viscosity</td>
</tr>
<tr>
<td>GetRho</td>
<td>const int iCell const int iSurf double &amp;Rho</td>
<td>Get density.</td>
<td>Rho : density</td>
</tr>
<tr>
<td>GetRhoSolid</td>
<td>const int iCell const int iSurf double &amp;Rho</td>
<td>Get density in solid cell.</td>
<td>Rho : density</td>
</tr>
<tr>
<td>GetThermalDiffusivity</td>
<td>const int iCell const int iSurf double &amp;ThermDiff</td>
<td>Get thermal diffusivity</td>
<td>ThermDiff : thermal diffusivity</td>
</tr>
<tr>
<td>GetThermalDiffusivitySolid</td>
<td>const int iCell const int iSurf double &amp;ThermDiff</td>
<td>Get thermal diffusivity in solid cell.</td>
<td>ThermDiff : thermal diffusivity</td>
</tr>
<tr>
<td>GetThermalExpansion</td>
<td>const int iCell const int iSurf double &amp;ThermExp</td>
<td>Get thermal expansion ratio.</td>
<td>ThermExp : thermal expansion ratio</td>
</tr>
</tbody>
</table>
7. Data File Format
Here is the formats of data files used by the CCFD are described. Data beyond what is described here cannot be changed by users.

7.1 List of Files Used
The CCFD uses the following seven types of files. These files are generated by the GiD although the user can also generate them.

Input files

- **Init.dat**: File that describes the parameters to control the execution of CCFD.
- **Input.ini**: File that describes the initial condition data for calculations.
- **Node.dat**: File that describes the node data for calculation areas.
- **Elem.dat**: File that describes the element data for calculation areas.
- **Bound.dat**: File that describes the boundary conditions for calculation areas.

Output files

- **Result**: Files that store calculation results of the final steps of steady calculations and unsteady calculations.
- **Result#.out**: Files that store results during calculations when unsteady calculations are being performed. Outputs calculation results for every step specified in Step freq. Post process of section 4.2 Interval Data. Enter the number of steps in #. The calculation results of the final step are the same as Result.

7.2 File Formats

7.2.1 Init.dat

**Bold words** are values set in the GiD menu.

<table>
<thead>
<tr>
<th>Total number of nodes</th>
<th>Total number of elements</th>
<th>Number of Slip boundary elements</th>
<th>Number of pressure boundary elements</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Number of solid boundary elements

[Problem data]

**Monitoring Point**

<table>
<thead>
<tr>
<th>Number of scalar variables</th>
<th>Neumann temperature Number of boundary elements *1</th>
<th>Heat transfer coefficient Number of elements *1</th>
<th>Heat source Number of boundary elements *1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temperature Dirichlet</td>
<td>Neumann Scalar2 Number of boundary elements *1</td>
<td>Scalar2 transfer coefficient Number of elements *1</td>
<td>Scalar2 source Number of boundary elements *1</td>
</tr>
<tr>
<td>Scalar2 Dirichlet</td>
<td>Neumann Scalar2 Number of boundary elements *1</td>
<td>Scalar2 transfer coefficient Number of elements *1</td>
<td>Scalar2 source Number of boundary elements *1</td>
</tr>
<tr>
<td>Scalar3 Dirichlet</td>
<td>Neumann Scalar3 Number of boundary elements *1</td>
<td>Scalar3 transfer coefficient Number of elements *1</td>
<td>Scalar3 source Number of boundary elements *1</td>
</tr>
<tr>
<td>. . . . . . . . . . . . . .</td>
<td>. . . . . . . . . . . . . . . . . . . . . . . . . . .</td>
<td>. . . . . . . . . . . . . . . . . . . . . . . . . . .</td>
<td>. . . . . . . . . . . . . . . . . . . . . . . . . . .</td>
</tr>
<tr>
<td>Scalar# Dirichlet</td>
<td>Neumann Scalar# Number of boundary elements *1</td>
<td>Scalar# transfer coefficient</td>
<td>Scalar# source</td>
</tr>
</tbody>
</table>
GiD CFD

<table>
<thead>
<tr>
<th>Number of boundary elements</th>
<th>Number of elements</th>
<th>Number of boundary elements</th>
</tr>
</thead>
</table>

|-----------------------------|-------------------------------|------------------------------------------------------|-----------------------|---------------------|

<table>
<thead>
<tr>
<th>[Interval Data] Step freq. Post process</th>
<th>[Problem Data] Restart</th>
<th>Analysis Type1</th>
<th>Analysis Type2</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>(On = 1, Off = 0)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

|-------------------------------------|-------------------------------------|-------------------------------------|-------------------------------|-------------------------------|

*1: The number of data will change depending on the number of scalar variables. When the number of scalar variables is 0, this portion will become zero.

*2: Combinations of analysis types 1 and 2 of the Problem Data menu become the following values.

<table>
<thead>
<tr>
<th>Analysis type 1</th>
<th>Analysis type 2</th>
<th>Analysis Type 1</th>
<th>Analysis Type 2</th>
<th>Analysis Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>STEADY</td>
<td>NO</td>
<td>0</td>
<td>0</td>
<td>Steady</td>
</tr>
<tr>
<td>STEADY</td>
<td>ke</td>
<td>0</td>
<td>1</td>
<td>Steady+k-ε</td>
</tr>
<tr>
<td>STEADY</td>
<td>LES</td>
<td>0</td>
<td>2</td>
<td>Steady+LES</td>
</tr>
<tr>
<td>USTEADY</td>
<td>NO</td>
<td>1</td>
<td>0</td>
<td>Unsteady</td>
</tr>
<tr>
<td>USTEADY</td>
<td>ke</td>
<td>1</td>
<td>1</td>
<td>Unsteady+k-ε</td>
</tr>
<tr>
<td>USTEADY</td>
<td>LES</td>
<td>1</td>
<td>2</td>
<td>Unsteady+LES</td>
</tr>
</tbody>
</table>

7.2.2 Input.ini

<table>
<thead>
<tr>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>Analysis Type1 *1</th>
<th>Analysis Type2 *1</th>
</tr>
</thead>
</table>

Element ID1

<table>
<thead>
<tr>
<th>Mass flow rate of surface 1 of element 1</th>
<th>Mass flow rate of surface 2 of element 1</th>
<th>Mass flow rate of surface 3 of element 1</th>
<th>Mass flow rate of surface 4 of element 1</th>
<th>Mass flow rate of surface 5 of element 1 *2</th>
<th>Mass flow rate of surface 6 of element 1 *2</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Prev Press</th>
<th>Press</th>
<th>Vx</th>
<th>Vy</th>
<th>Vz</th>
<th>k</th>
<th>e</th>
<th>Temp</th>
<th>Scalar2</th>
<th>. . .</th>
<th>Scalar#</th>
<th>MuTau</th>
</tr>
</thead>
</table>

Repeated number of elements on and after the second line

Prev Press: Pressure before step 1
Press: Pressure
Vx: X-direction velocity
Vy: Y-direction velocity
Vz: Z-direction velocity
k: Turbulent energy
e: Viscous dissipation rate
Temp: Temperature
Scalar2: Scalar 2

..._scalar#: Scalar #
MuTau: Turbulent flow viscosity coefficient

*1: Value identical to init.dat.
*2: Enter 0 when element shape is a four-sided body.

### 7.2.3 Node.dat

<table>
<thead>
<tr>
<th>Total number of nodes</th>
<th>Node ID maximum value</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Node</th>
<th>ID</th>
<th>X coordinate value</th>
<th>y coordinate value</th>
<th>z coordinate value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node ID1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Node ID2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

Total repeated number of nodes on and after the second line 2

### 7.2.4 Elem.dat

<table>
<thead>
<tr>
<th>Total number of elements</th>
<th>Element ID maximum value</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Node ID1</th>
<th>Node ID2</th>
<th>Node ID3</th>
<th>Node ID4</th>
<th>Viscosity</th>
<th>Thermal diffusion coefficient</th>
<th>Density</th>
<th>Thermal expansion rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Tetra element**

<table>
<thead>
<tr>
<th>Element Type</th>
<th>*1</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Node ID1</th>
<th>Node ID2</th>
<th>Node ID3</th>
<th>Node ID4</th>
<th>Viscosity</th>
<th>Thermal diffusion coefficient</th>
<th>Density</th>
<th>Thermal expansion rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Hexa element**

<table>
<thead>
<tr>
<th>Element Type</th>
<th>*1</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Node ID1</th>
<th>Node ID2</th>
<th>Node ID3</th>
<th>Node ID4</th>
<th>Node ID5</th>
<th>Node ID6</th>
<th>Node ID7</th>
<th>Node ID8</th>
<th>Viscosity</th>
<th>Thermal diffusion coefficient</th>
<th>Density</th>
<th>Thermal expansion rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Repeated number of elements on and after the second line

*1: Element Type=6 Tetra element, Element Type=8 Hexa element
### 7.2.5 Bound.dat

#### Number of slip boundary elements

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tetra element</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hexa element</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Repeated number of slip barrier elements

Value: x-direction slip = 1, y-direction slip = 2, z-direction slip = 3

xy-direction slip = 12, xz-direction slip = 13, yz-direction slip = 23, xyz-direction slip = 123

#### Number of velocity boundary elements

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
<th>Surface 5</th>
<th>Surface 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tetra element</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hexa element</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### CFD GiD

#### Surface 1
- **x-direction value**
- **y-direction value**
- **z-direction value**

#### Surface 2
- **x-direction value**
- **y-direction value**
- **z-direction value**

#### Surface 3
- **x-direction value**
- **y-direction value**
- **z-direction value**

#### Surface 4
- **x-direction value**
- **y-direction value**
- **z-direction value**

#### Surface 5
- **x-direction value**
- **y-direction value**
- **z-direction value**

#### Surface 6
- **x-direction value**
- **y-direction value**
- **z-direction value**

**Repeated number of velocity boundary elements**

**Flag:** Flag=0 sets without velocity boundary, Flag=1 sets with velocity boundary

**Value:** Velocity of vector in X,Y,Z directions (type: double)

#### Number of pressure boundary elements

**Tetra element**

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Surface 1 Flag</th>
<th>Surface 1 value</th>
<th>Surface 2 Flag</th>
<th>Surface 2 value</th>
<th>Surface 3 Flag</th>
<th>Surface 3 value</th>
<th>Surface 4 Flag</th>
<th>Surface 4 value</th>
</tr>
</thead>
</table>

**Hexa element**

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Surface 1 Flag</th>
<th>Surface 1 value</th>
<th>Surface 2 Flag</th>
<th>Surface 2 value</th>
<th>Surface 3 Flag</th>
<th>Surface 3 value</th>
<th>Surface 4 Flag</th>
<th>Surface 4 value</th>
<th>Surface 5 Flag</th>
<th>Surface 5 value</th>
<th>Surface 6 Flag</th>
<th>Surface 6 value</th>
</tr>
</thead>
</table>

**Repeated number of pressure boundary elements**

**Flag:** Flag=0 sets without pressure boundary, Flag=1 sets with pressure boundary

**Value:** Pressure (type: double)

#### Number of solid elements

<table>
<thead>
<tr>
<th>Element Type</th>
<th>Element ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

**Repeated number of solid elements**

#### Number of scalar data blocks (number of scalars)

**Number of temperature boundary elements**
### Tetra element

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Surface 1 value</th>
<th>Surface 2 value</th>
<th>Surface 3 value</th>
<th>Surface 4 value</th>
</tr>
</thead>
</table>

### Hexa element

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
<th>Surface 5</th>
<th>Surface 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Surface 1 value</th>
<th>Surface 2 value</th>
<th>Surface 3 value</th>
<th>Surface 4 value</th>
<th>Surface 5 value</th>
<th>Surface 6 value</th>
</tr>
</thead>
</table>

*Repeated number of pressure boundary elements*

Flag: Flag=0 sets without temperature boundary, Flag=1 sets with temperature boundary

Value: Temperature (type: double)

### Number of heat flux boundary elements

| Tetra element
<table>
<thead>
<tr>
<th>Element Type</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Surface 1 value</th>
<th>Surface 2 value</th>
<th>Surface 3 value</th>
<th>Surface 4 value</th>
</tr>
</thead>
</table>

| Hexa element
<table>
<thead>
<tr>
<th>Element Type</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
<th>Surface 5</th>
<th>Surface 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Surface 1 value</th>
<th>Surface 2 value</th>
<th>Surface 3 value</th>
<th>Surface 4 value</th>
<th>Surface 5 value</th>
<th>Surface 6 value</th>
</tr>
</thead>
</table>

*Repeated number of heat flux boundary elements*

Flag: Flag=0 sets without heat flux boundary, Flag=1 sets with heat flux boundary

Value: Value that excludes heat flux at specific heat (type: double)

### Number of heat transfer boundary elements

| Tetra element
<table>
<thead>
<tr>
<th>Element Type</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Surface 1</th>
<th>Surface 2</th>
<th>Surface 3</th>
<th>Surface 4</th>
</tr>
</thead>
</table>
### Element Type

<table>
<thead>
<tr>
<th>Flag</th>
<th>Flag</th>
<th>Flag</th>
<th>Flag</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface 1 value</td>
<td>Surface 2 value</td>
<td>Surface 3 value</td>
<td>Surface 4 value</td>
</tr>
</tbody>
</table>

**Hexa element**

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Surface 1 Flag</th>
<th>Surface 2 Flag</th>
<th>Surface 3 Flag</th>
<th>Surface 4 Flag</th>
<th>Surface 5 Flag</th>
<th>Surface 6 Flag</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface 1 value</td>
<td>Surface 2 value</td>
<td>Surface 3 value</td>
<td>Surface 4 value</td>
<td>Surface 5 value</td>
<td>Surface 6 value</td>
<td></td>
</tr>
</tbody>
</table>

Repeated number of heat transfer boundary elements

Flag: Flag=0 sets without heat transfer boundary, Flag=1 sets with heat transfer boundary
Value: Value that excludes heat transfer coefficient at specific heat (type: double)

### Number of heat source elements

<table>
<thead>
<tr>
<th>Element ID</th>
<th>Heat source</th>
</tr>
</thead>
<tbody>
<tr>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

Repeated number of heat source elements

*1: The scalar data block is one block of the blue line portion. Repeats the number of scalar blocks to be calculated.

### 7.2.6 Result, Result#.out

Result, Result#.out are common formats.

<table>
<thead>
<tr>
<th>Total number of time step</th>
<th>Execution time step</th>
<th>0</th>
<th>0</th>
<th>Analysis Type1 *1</th>
<th>Analysis Type2 *1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element ID1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

| Mass flow rate of surface 1 of element 1 | Mass flow rate of surface 2 of element 1 | Mass flow rate of surface 3 of element 1 | Mass flow rate of surface 4 of element 1 | Mass flow rate of surface 5 of element 1 *2 | Mass flow rate of surface 6 of element 1 *2 |

<table>
<thead>
<tr>
<th>Prev Press</th>
<th>Press</th>
<th>Vx</th>
<th>Vy</th>
<th>Vz</th>
<th>k</th>
<th>e</th>
<th>Temp</th>
<th>Scalar2</th>
<th>...</th>
<th>Scalar#</th>
<th>MuTau</th>
</tr>
</thead>
</table>

Repeated number of elements on and after the second line

- **Prev Press**: Pressure before step 1
- **Press**: Pressure
- **Vx**: X-direction velocity
- **Vy**: Y-direction velocity
- **Vz**: Z-direction velocity
- **k**: Turbulent flow energy
- **e**: Viscous dissipation rate
- **Temp**: Temperature
- **Scalar2**: Scalar 2
- ... , **Scalar#**: Scalar #
- **MuTau**: Turbulent flow viscosity coefficient
... 

*1: Value identical to init.dat.
*2: Enter 0 when element shape is a four-sided body.