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1. Introduction
1.1 GiD-CCFD

A GiD is an interactive graphic user interface for defining, preparing, and displaying all data related to numerical
simulations. Shapes, materials, conditions, solution methods, and definitions of other parameters are included in the data.
This interface generates meshing used for finite elements, finite volumes, or finite difference analyses. The GiD can also
write data in formats required by numerical simulation programs. Numerical simulations can be executed and analysis
results displayed from within the GiD.

The GiD-CCFD is customized with more additional functions than the GiD for use with thermohydrodynamic analysis
software CCFD. Therefore, it can create computational models of CCFD and plot analysis results (post processing).

The flow of an analysis using the GiD-CCFD is shown below.

e Create geometry or input from CAD data

e  Specify analysis control data for CCFD

e Create material data

e Create boundary conditions for geometry

e  Set meshing size to geometry

e Create meshing

e Create boundary conditions for meshing (option)

e Execute analysis using the CCFD (use separate CCFD)
e Plot CCFD results

1.2 Using this Manual

This manual should be used when using the GiD-CCFD for the first time, and it is written to allow the basic usage
methods of the GiD and CCFD to be learned through exercises.

This manual is divided into four sections.

Section 1 describes starting and closing the GiD-CCFD. This section describes starting projects, saving projects, and
quitting the GiD-CCFD.

Section 2 describes CFD analysis using the GiD-CCFD. This section teaches methods to define shapes (geometry)
and analysis data as well as methods to create meshing through exercises. Executing an analysis and post processing
are also introduced.

Section 3 provides a reference for the Data menu of the GiD-CCFD, as well as a command reference for the GiD-CCFD
analysis interface.

Section 4 provides a reference for the data file format of the GiD-CCFD, as well as the formats of data files used with
the GiD-CCFD.
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2. Starting and Quitting GiD-CCFD
2.1 Starting GiD-CCFD
Start the GiD-CCFD from the Taskbar by selecting GiD 7.2 on the Start > Program > GiD 7.2 menu.

To create a new model after starting the GiD-CCFD, begin the operation with the program as-is at startup. To read a
model created beforehand, select the Open command from the Files menu.

Project: UNNAMED.

Files  View Geometry Utilities Data Meshine Galculate Help

Ao MGIvreear|a biDve=en?

3

L

This is the PROFESSIONAL Yersion.
Command; I

LBV IFEAIDLD /O hE

ENE

The Read Project dialog box will be displayed. Select the folder where the GiD Project file is located (“.gid” will be
appended to the folder name and should be visible as one file in the Read Project dialog box) and click OK.

Read Project ]
Diirectary: C:5Program Filez\GIDAGID Y. 2 — | ﬂ
— 1 audio | templates
| bitmaps backup.gid
| Examples
=1 info
= | problemtypes
| scrpts
| symbols
1 na
File name: I Open
Filez of type:  GID project [*.gid) — | Cancel
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2.2 Saving a GiD-CCFD Project

GiD-CCFD data is divided into multiple files in one project. Saving a project saves all files (shapes, conditions, materials,
meshing, etc) related to that project to disk.

Select the Files > Save command. The Save Project dialog box will display. In order to save a project, the GiD creates a
directory to which the extension “.gid” is appended to the name. Depending on the files, all information is written to that
directory and the GiD-CCFD can handle the directory of this project as a file.

The user must enter the “.gid” extension. The extension is automatically added to the directory name.

CAUTION: You must be careful with files when manually changing a Project.gid directory. When this is done, there is a
danger that several pieces of information might be destroyed.

2.3 Quitting GiD-CCFD
Select the Files > Quit command to quit the GiD.

If the most recent data has not been saved, a confirmation dialog box will display asking whether you want to save the
data before quitting the program. To save, select “Yes.” Select “No” if don’t want to save. Select Cancel to return to the
program.

Dialog window ]

9 Save changes before quitting?

Mo Cancel
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3. CFD Analysis using GiD-CCFD

Here, creating computational models of pre-processing, CFD analysis, and post-processing using the GiD-CCFD can be
briefly experienced through exercises.

3.1 Outline of the Exercise

Turbulent flow step flow (a regular two-dimensional turbulence problem) h = 3.81, x-direction fixed flow velocity (air) 18.2
m/s

6 partitions

8 partitions

| 25 partitions

3.2 Creating Geometry

First creating and working with a geometry entity in the GiD will be introduced.

Open the GiD and start program operations. A new GiD program will be automatically created.

Let’s create a geometry entity from this new GiD program.

3.21 Creating Points and Lines

To begin, we will determine a start point (point 1) and an end point (point 2) and then create a straight line. The
coordinates are 0,0,0 and 80.01, 0,0, respectively.

To create a point, simply use an Auxiliary Window to enter the coordinates of the desired point location. This is done by
opening the Coordinates Window dialog box the following order: Utilities>Graphical->Coordinates Window.

Next, select Geometry->Create->Point from the Top Menu. The mouse cursor will change from an arrow to a cross.

Take the following step in the already opened Coordinates Window dialog box.

Goordinates window
C. Syztem; Cartezian —
(2) Click the Apply button or
Local axes: Global- — press the Enter key to create
point 1.
(1) Enter b
coordinates of
point 1 v |0.00000
z |0.00000
Mew point: | Ask/” Change
I1ze tab Shift-tab and Return'

Apply | Close |

In the same manner, enter the coordinates in the Coordinates Window to create the following points.
Point 2: Coordinates (80.01, 0, 0)
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Point 3: Coordinates (80.01, 7.62, 0)
Point 4: Coordinates (0, 7.62, 0)
Point 5: Coordinates (-15.24, 7.62, 0)
Point 6: Coordinates (-15.24, 0, 0)
Point 7: Coordinates (0, -3.81, 0)
Point 8: Coordinates (80.01, -3.81, 0)

To complete point creation, in the same manner as other commands, either press the Escape button on the keyboard or
click the center mouse button. The mouse cursor will return to an arrow from the cross shape. Select Close to close the
Coordinates Window.

3.2.2 Adjusting the Display
Select the following command to allow all created points to be displayed within the range of the screen.
View>Zoom->Frame

3.23 Creating Lines

Here we will combine two points to create a line. Advance from the Top Menu and select the following.
Geometry->Create->Line

You can also use the option in the Toolbar shown below.

N

Next, we will determine the start point of the line. In order to select the points already created on the screen, click the
right mouse button to open the Mouse Menu and select Contextual->Join C-a.

na Note: Using Join you can select the points already created on the screen. The No Join command allows you to
create new points with the same coordinates as the points selected on the screen. The cursor shape is different for Join
and No Join.
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=] Cursor when usina the Join command
il Cursor when usina the No Join command

E3

Create point procedure

Select the exizting paint or create a new ong?

[5]

No join Join
new point existing point
is created is selected

NOJOIM \

MOTE: Chil-a toggles between Jain and Mo join modes.

Cancel

Help ‘

Select point 1 as the first point and point 2 as the second point and then determine the line according to these.

To continuously create a line that continues from the beginning and end, continuously specifying a second point will
continuously generate the line. In this manner, create each line shown below.

Line 2: Point 2 — Point 3
Line 3: Point 3 — Point 4
Line 4: Point 4 — Point 1

Click the Escape key when you want to change the start point of the line.

Line 5: Point 4 — Point 5
Line 6: Point 5 — Point 1
Line 7: Point 6 — Point 1
Line 8: Point 1 — Point 7
Line 9: Point 7 — Point 8
Line 10: Point 8 — Point 2

After all lines are created, click the Escape key twice to complete line creation.

3.24 Displaying Labels
Select the following command to display all created points and line labels.
View->Label>All
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Project: UNNAMED TEX
Files  View Geometry Utilities Data Meshine Galculate Help
AT MG IDeeeIGRI4 biDve=ens
A
g
&
&
N
o ab 4
o2 BE73 1 é
‘g’) id il B0
pt
¥iw
&
B[
%
[ if present, mouse wheel zooms dynamically) Enter 1st point L}
Fepeating function j
Command: |

3.25 Zoom Display
Select the following command to zoom the display of one portion of a model.
View>Zoom->In

This will change the cursor to a thin black cross. Specify the display range you want to zoom. First, click the mouse once
to specify the start point of the display range you want to zoom. Then, move the mouse to determine the display range
you want to zoom. Clicking the mouse once at a suitable area will confirm the display range you want to zoom, and then
zoom the display.

bl Gin Project: UNNAMED CEx
Files=  View Geometry Utilities Data Meshine Caloulate  Help

Ao GG Te( @7 biDve=en?
A

%

L+

v

o aho4

: e

"

&

B |,

[ if present, mouse wheel zooms dynamically) Enter 13t paint L}
Enter 2nd point j
Command: | .

A screen with a zoomed display is shown below.
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Project: UNNAMED

Files  View Geometry Utilities Data Meshine Galculate Help

AT MG IDeeeIGRI4 biDve=ens
A

g

LFS

&

N\ § 4

‘\

@ 1

&

<l 7 I

¥iw

B

e :

&

L

%

[ if present, mouse wheel zooms dynamically) Enter 1st point ﬁ
Enter 2nd paint j
Command: |

3.2.6 Generating Surfaces

Display the entire model using the method described above, namely,

View->Zoom->Frame from the Top Menu.

Next, generate a surface as shown below.

Select the following from the Top Menu.

Geometry->Create>NURBS surface->By contour

Sequentially select line 1 — line 2 — line 3 — line 4. If you click the Esc key and complete specifying the lines, a surface

will be generated. Clicking the Esc key once again will complete the surface generation. In the same manner, generate a
surface of line 4 —line 5 — line 6 — line 7 and line 1 —line 8 —line 9 — line 10.

Select the following command to display all created points and lines as well as surface labels.
View->Label>All

Project: UNNAMED

Files  View Geometry Utilities Data Meshine Galculate Help

AT MG IDeeeIGRI4 biDve=ens

2l
&3l

e =2 15
gz 2 70
(=)

-

[ if present, mouse wheel zooms dynamically) Enter 1st point
Fepeating function

BN IFEAIRDD /IO

[N

Command: |

The points and their labels will be displayed in black, the lines and their labels will be displayed in blue, and surfaces and
their labels will be displayed in pink.
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3.2.7  Generating Volumes
Generate volumes as shown below.
Select the following from the Top Menu.
Utilities >Copy

Gopy (]
Entities type:  Surfaces —
Transformation:  Translation —4

First point
MNum: = lr
| v |00
Second paint
Mur: = lr
| T3 |EI.EI

@ o[22

[ Duplicate entiies

Doestrude: Yolumes —

[ Create contacts
[ Maintain layers
tultiple copies: |1

Select | Caricel |

For Entities type select Surfaces using the geometry type selection targeted for copying. Transformation should be
Translation. Also enter coordinates of SecondPoint to determine the thickness in the z-axis direction.

Do extrude should be Volumes. Next, click Select and select surface 1, surface 2, and surface 3 and then press the
Esc key (or click Finish). This will copy the surfaces and generate volume 1, volume 2, and volume 3.
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Project: UNNAMED

Files  View Geometry Utilities Data Meshine Galculate Help

AT MG IDeeeIGRI4 biDve=ens
A
2,

Y

s

%P\ck LEFTMOUSE to rotate [ESC to quit).
ngck LEFTMOUSE ta ratate [ESC to quit),

BN IFBAIRDD /T e

Ll I

Command: |

3.3 Setting Analysis Conditions
3.3.1 Setting Analysis Type

Specify FINAS as the solver used for the analysis and select the analysis type (static stress analysis, condition analysis,
dynamic analysis, CFD analysis). This allows you to set analysis conditions which correspond to the predetermined
analysis type of FINAS.

Because CFD analysis is selected here, select the following from the Top Menu.
Data->Problem Type->FINAS->CFD

The following warring screen will appear. Namely, if the solver used for the analysis or the analysis type changes after
setting the analysis conditions, the analysis conditions will be lost. Please use caution. Click OK. This will change the
pull-down menu of the Data menu of the Top Menu to the menu for CFD analysis of FINAS.

Dialoe window X]

All data
9 information(materials, conditions,d
ata) will be lost. OK?

cancel

3.3.2  Setting Analysis Control Data
Set analysis control data. Select the following from the Top Menu.
Data->Problem Data

The Problem Data dialog box shown below will display.

As an example, enter “STEP FLOW ANALYSIS” as a title for the analysis problem in the TITLE input field. For the Type
of problem select STEADY and for the Turb model select ke (k-¢). For the Sweep select 100.
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When you finish entering the data, click Accept data to validate the data. Click the Close button to close the dialog box.

problemdata

& [

General ] Restart ] Monitoring pnint] Scalar ] Coupling ]
TITLE |backstep

Type of problem;  STEADY —

Tubmodel: ke —
Sweep:"lﬂﬂi
Relax factar: lﬂﬂi
Relax factar P: ’&27
Scheme[l.0-1.0k (00

Accept data Lloze

3.33 Defining Material Data
Select the following from the Top Menu.
Data->Materials

The material dialog box shown below will display.
Next, Select AIR for Materials. Click the Assign button to select Volumes.

Select volume 1, volume 2, and volume 3. After the selection, click the Esc key to complete the volume selection. Click
the Esc key once again, or click the Close button to close the dialog box.
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Matorials )|
IR X8| |

DEMSITY [1.189
YISCOSITY |1.836E-5
TERMAL DIFF COEF |2.567E-5
ExCO|2.41E-3

Assign Qraw| unassign| Impart/E «port

Cloze

3.3.4 Defining Conditions
Select the following from the Top Menu.

Data->conditions>boundary
The boundary dialog box shown below will display.

Select FIXED-VELOCITY and set the values for X-Value, Y-Value, and Z-Value to 0. Next, click the Assign button and
select surfaces 6, 8, 10, 11, and 12. After the making the selection, click the Esc key to complete the surface selection.
Next, set the value of the X-Value of FIXED-VELOCITY to 18.2 and in the same manner as before select surface 9 to
complete the surface selection. Thereafter, select FIXED-PRESSURE and set the value of PRESSURE to 0. Click the
Assign button and select surface 5. After the making the selection, click the Esc key to complete the surface selection.
Click the Esc key once again or click the Close button to close the dialog box.
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CGonditions

FI=EDWELOCITY g ﬂ
#Adalue (0.0

W alue (0.0
M alue (0.0

Cloze

3.35 Setting Interval Data
Select the following from the Top Menu.
Data->Interval

The Interval dialog box shown below will display.

The STEP input field is where you enter the number of steps.

13
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Interval Data
i 3 @ x?

Control ] Gravity ]Eriteriun temp]

MHumber of Steps: |1
Time ztep increment: |1 A
Step freq. post process:; |1 Q000

o 7]

?gccept data Cloze

Lastly, click the Accept data button to make the defined step data valid. Click the Close button to complete the Interval
dialog box.

3.3.6  Setting Initial Data

Select the following from the Top Menu.

Data->Conditions->Initial
The Initial dialog box shown below will display.

The STEP input field is where you enter the number of steps.

14 CTC
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iy

InitialV alie *| 3

[ritial % alue [Pres] |0.0
Imitial W alue [4]: |0.0
[ritial % alue [yl 0.0
[ritial % alue [We] 0.0
Imitial % alue [Temp]: (0.0

[ritial % alue [Fe] |1.0E-10

Iritial % alue [Ep]: |1.0E-10

Azzign | Entities| Qraw| unassign|

LCloze

Here we use default values for this problem. Click the Assign button, and select volume 1, 2 and 3. Lastly push Esc key
to finish volume selection.

3.4 Meshing Generation

3.41 Setting Meshing Element Type
Select the following from the Top Menu.

Meshing->Element type->Hexahedra

information window X

9 Select volumes to assign elem
type: Hexahedra

3.4.2  Setting Number of Meshing Partitions
Select the following from the Top Menu.

Meshing-> Structured->Volumes
Select volume 1, volume 2, and volume 3.
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Project: Sample
Files  Miew Geometry Utilities Data  Meshing Calculate  Help

AHood MG Iveresard bibvesen?

F.

BRIFEAIND /& Ps

ko

Select B-sided volumes to define structured mesh _:j
Added 3 new volumes to the selection. Enter more volumes. [ESC to leave] j
-

Command: |

If you click the Esc key to complete the volume selection after the selection, the Enter value window dialog box shown
below will display. Enter 21 for the number of partitions on line 11, and click the OK button to select line 11. All lines are
selected in the same manner as line 11. After the selection, click the Esc key to complete the line selection. In the same
manner, set 16 partitions for line 14, four partitions for line 17, eight partitions for line 18, and one partition for line 27.
Click the Esc key or click the OK button to close the dialog box.

Enter value window

Enter another number of cells to
assign to lines

21
1

343 Meshing Generation
Select the following from the Top Menu.

Meshing-> Generate
The Enter value window dialog box shown below will display. Use the default value for the element size and click OK. A
square shaped meshing will be automatically generated when this is done.
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Enter value window ]

Enter size of elements to be
generated

3¢ ~]
k. Cancel

When the meshing generation is complete, the following message will display. Verify and then click OK.

Dialoe window

Mesh Generated. Press 'OK' to
sae jt

Murm. of Hexahedra elementz=568
MHum. of nodez=1236

Generated meshing will display as shown below. Analysis conditions are converted to finite elements and articulation
points. When analysis conditions are modified after meshing generation, the meshing must be generated again.

Project: Sample |Z||E|E|
Files iew Geometry Utilities Data Meshing GCalculate  Help
N/.;-% ®©@|ﬁ<§|@®@§‘@?"ﬂ [iil]\l'ersion?
p "y
T
LFS
9
v
N\
N
o
&
<
()
"
B L
= N
. =l
Commatd: I
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GiD

Project: Sample

B

GiDve=en?

1

Files  View Geometry Utilities Data Meshine Galculate Help
AH OO MG Qe s G2
[

A

‘s

&

a

R

& &\

- X

HLEE &

Fick LEFTMOUSE to rotate [ESC to quit) [ if present, mouse wheel zooms)
Pick LEFTMOUSE to ratate [ESC to quit]

Command: |

3.5 Saving Files

Select the following from the Top Menu.

Files>save as ...

The Save Project dialog box will display. In order to save a project, the GiD creates a directory to which the extension
“.gid” is appended in the name. The directory of this project can be handled as a file by the GiD-CCFD.

The user is not required to enter the “.gid” extension. The extension is automatically added to the directory name.

If you enter “Sample” and click Save, a Sample.gid directory will be created in the specified directory.

Save Project X

Diirectary:

C:AProgram Filezs\GIDAGID Y. 2

4|ﬂ

LA ALl 4L

F

audio = | templates
bitmapz backup.qid
Examples

ihfo

problemtypes

zonipts

gumbolz

File name; |Sampld

Files of typer  GID project [%.gid)

Save

— | Cancel

3.6 Executing Analysis

3.6.1 Analysis

Select the following from the Top Menu.

Calculate->Calculate window ...

18
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The process window dialog box shown below will display. Click Start here. When clicked, CCFD data will be created

and the analysis executed by CCFD.

Process window

Project  Start time  UID

ES)

o

Clutput view | kil

Start | Start remote |

Remate... |

Cloze |

In addition, if you select the following from the Top Menu, CCFD data will be created immediately and the analysis

executed by CCFD.

Calculate->Calculate

If CCFD data is successfully generated with GiD, following window will be appear. If there is no problem in descriptions in
following window, click “Exit” button. Then CCFD starts calculation. if some error messages appear in the window, check

your input data again.
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B TRANSLATOR

abal vals TYPE LoaTEaDY

TURBULENWCE MODEL : K-E

SWEEP : 100
RLAKATION FACTOR Yel : g.00000E-01
RELAXTION FACTOR P 2.00000E-01
GRAYITY 0.00000E+0D
GRAYITY YECTOR GX 0.00000E+0D
GRAYITY YECTOR GY : 0.00000E+0D
GRAYITY YWECTOR GZ : -1.00000E400
CRITICAL TEMPERATURE O.00000E+00
RESULT FILE OQUTPUT IWTERWAL : 100
MUMBER OF ELEMENT : HED
NUMBER 0OF MWODE : 1236
MUMBER OF YELOCITY BOUNDAY : 1
WUKMEER OF FRESSURE BOUNWDAY 24

————————— NORMAL TERMINATION ---------

When the analysis is complete, the process info dialog box shown below will display.

Process info X]

Process 'Sample’ started at Thu
Apr 15 16:14:43 has finished.

AT

Click Postprocess.

The input files fvm_ke_out.inp, fvm_out.inp, Result, temp_out.inp, and Sample.post.res will be created in the Sample.gid
directory. When these files are not created, you can assume some sort of error occurred. For this case, output.out
created in the directory is useful for investigating the cause of the error.

3.6.2 Displaying Pictures
Select the following from the Top Menu.
View Results>Contour Fill>Ep

The Ep picture shown below will display on the screen.
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Project: Sample

Files  Wiew Wilities Do cutz  Wiew results  Options  Windows  Help

ACoa|&ig|vere a? |4 GiDve=ey

|, ¢ Lou™ 8

~

=

P

By 15552
13.824

AN I 12.098

i - 10.368

= 0.6401

o Mg

- 5184

Command: |

21
B 34562
l-? 17282
i 0.0001976
Contowr Fill of Ep
Enter variable name d
Contour Fill'Ep'; Min = 0.0001976, Max = 15.552 j

Select the following from the Top Menu.

View Results->Contour Fill>Ke
A distribution obtained by a k-¢ fill on the figure shown below will display.

Project: Sample

Eiles  Miew UWilities Do cuts  Wiew results Options  Windows  Help

AU &G IPeeeIR?Id Gibvemen?
b
e

[“s s

w
P
— Ke
5 11,604
A I 10.316
9.0272
iy S 77336
= B 4289
of [ ERTAE
S | 38726
2584
y 1.2054
00067075
L %

Cortour Fill of Ke.

Enter variable name
Contour Fill 'e'. tin = 0.0067075, Max = 11.604

Ll I+

Command: |

Select the following from the Top Menu.

View Results>Contour Fill>Pressure
The distribution obtained by a Pressure fill on the figure shown below will display.
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GiD

Project: Sample

Miew Utilities Do cuts  View results

Options  Windows  Help

W@t

¥

FIEFE e

21
17
B
4 v
A
P
WS k %

ool agbresiaria

Contour Fill of Pressure.

Em Version 7

& AN

FPressurs

i 18.392
9.6658
0.93a87

+-T.7EE1
+-16.512

. -25.238

-33.964
I -42.69
-51.418
-60.142

Enter variahle name
Contour Fill ‘Pressure’. Min = -B0.142, Max = 18,392

Command: |
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4. Free surface flow analysis

Here, creating computational modelsof pre-processing, CFD analysis, and post-processing for free surface flow analysis
using the GiD-CCFD can be briefly experienced through exercises.

4.1 Outline of the Exercise

The backstep flow model created in the chapter 3 will be used. Here, it is assumed that flow is two dimensional, unsteady
and inlet velocity is 1.0 m/s along x-direction.

4.2 Reading a GiD project

Start the GiD. And open the project of the backstep flow model created in the chapter 3, or the example project
(backstep.gid). Then save the project in another name (ex. backstep_vof.gid). After saving project, select the following
from the Top Menu in order to initialize analysis conditions.

Data — Problem type — CFD

Then, select the following from the Top Menu.
Utility—Move...

For Entities type select Volumes and for Transformation select Scale. For Scale factors enter 0.01.

Entities type: |%olumes -
Tranzformation: |Scale A

Fumn: w (0.0

Center

| w [0
e z |00

Scale factors
[v Same factors

w007
v [0
z [0m

[ Duplicate entities

Do estrude: |Mo 7

=

Iv Maintain layers

tultiple copies: |1

Select Cancel

Then click Select button and select volume 1, volume 2, and volume 3. After the selection, click the Esc key to complete
the volume selection. Click the Esc key once again, or click the Close button to close the dialog box.
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4.3 Setting Analysis Conditions
4.31 Setting Analysis Type

Set analysis control data. Select the following from the Top Menu.
Data—Problem Data

The Problem Data dialog box shown below will display.

As an example, enter “backstep_vof” as a title for the analysis problem in the TITLE input field. For the Type of problem
select UNSTEADY and for the Turb model select NO(laminar flow). For the Sweep select 30. For the Relax factor enter
0.7. For the Relax factor P enter 0.3.

----- x
r? )
General ] Restat | Maritoring point | Scalar | VOF | Coupling |

TITLE |backstep_wof
Type of problem: IMSTEADY —

Tubmodel, WO —

Sweep: |30

Relax factor: (0.7
Rela Factor P: |03
Scheme(0.0-1.0]: 0.0

Accept Cloze

Next, select the Scalar tab and select “TEMPERA” and “Scalar2” check box.
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General ] Restart ] Monitoring point— Scalar l YaF ] Coupling

[v TEMPERA:
v Scalar2:
[ Scalar3:
[ Scalard:
[ Scalars:

Next, select the VOF tab. The conditions for free surface flow problems and material properties of the 2nd phase can be
defined in this tab. Select “Use VOF” check box.

----- x
r? )
General ] Restart ] Muanitaring paint ] Soalar  YOF ] Coupling ]

v UsevOF

number af phaze: |2
Courant number: {0.3
phasze2 WISCOSITY: |1.836E-5
phaze? TERMAL DIFF COEF: [2.567E-5
phaze? DEMSITY: [1.189
phase? EXC0: [3.41E-9

Accept Cloze

When you finish entering the data, click Accept data to validate the data. Click the Close button to close the dialog box.

4.3.2 Defining Material Data
Select the following from the Top Menu.

Data->Materials
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The material dialog box shown below will display.

T4 Materials El
WATER rEBOX v

DEMSITY |998.23
YISCOSITY |1.004E-3
TERMAL DIFF COEF [1.428E-4

EXCO {1

Szgign Drraw Unaszzign E xchange

Cloze

Next, Select WATER for Materials. Click the Assign button to select Volumes.
Select volume 1, volume 2, and volume 3. After the selection, click the Esc key to complete the volume selection. Click

the Esc key once again, or click the Close button to close the dialog box.

The material properties defined here are treated as the properties for the 1st phase.

4.3.3  Setting Initial Conditions
Select the following from the Top Menu.

Data—Conditions—Initial
The Initial dialog box shown below will display.




GiD CFD

i

Iritial alue =

[ritial % alue [Pres] (0.0
Irmitial W alue [u]: |0.0
[ritial % alue [yl |0.0
[ritial W alue W] |0.0

Imitial % alue [Temp]: (0.0
[ritial % alue [Fe] |1.0E-10
Iritial % alue [Ep]: |1.0E-10

Iritial Y alue [Scalar2]; (0.0
Iritial % alue [Scalar3): (0.0
Imitial W alue [Scalard]: (0.0
Iritial % alue [Scalars]: (0.0

Azzign Entities Diraw Unaszszign

Cloze

Select volume 1, volume 2, and volume 3. After the selection, click the Esc key to complete the volume selection. Click
the Esc key once again, or click the Close button to close the dialog box.

4.3.4 Defining Boundary Conditions
Select the following from the Top Menu.

Data—conditions—Boundary
The Boundary dialog box shown below will display.




CFD GiD

SE

FI<EDAELOCITY - k2

HAalue 0.0
4 alue (0.0
£ alue 0.0

Azsign Entities Dirawy Unasszign

Cloze

Select FIXED-VELOCITY and set the values for X-Value, Y-Value, and Z-Value to 0. Next, click the Assign button and
select surfaces 6, 8, 10, 11, and 12. After the making the selection, click the Esc key to complete the surface selection.
Next, set the value of the X-Value of FIXED-VELOCITY to 1.0 and in the same manner as before select surface 9 to
complete the surface selection.

G
|[FEnvELDOITY v WG
Hfalue[10

Walue|0.0
ZValue|0.0

Finish  Press Finish' to end selection [Lnazsign

¥

A%

Thereafter, select FIXED-PRESSURE and set the value of PRESSURE to 0. Click the Assign button and select surface
5 and 13. After the making the selection, click the Esc key to complete the surface selection.

Close
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bgvs il
FIXED-PRESSURE - W
0.0
LFinish |
v
W x -
z [EU.U]

select FIXED-SCALAR2 and set the value of FIXED-SCALAR?2 to 1. Click the Assign button and select surface 9. After
the making the selection, click the Esc key to complete the surface selection.

Tt Boundary
e
FINED-SCALARZ . g

Click the Esc key once again or click the Close button to close the dialog box.

4.3.5 Setting Interval Data
Select the following from the Top Menu.

Data->Interval
The Interval dialog box shown below will display.
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GiD

T intvdata

L S A2

Cortiol | Gravity | Criterion temp |

MHurnber of Steps: {100
Time step increment; |0.01
Step freq. post process: (5

For the Number of Steps enter 100. For the Time Step increment enter 0.01. For the Step freq. post process enter 5.

Next, select Gravity tab. In this tab magnitude and direction vector of the gravity acceleration can be specified. Enter

values as following figure.

1 O A2 )
Control - Gravity l Criterion temp |

Gravity Walue: (9.8
Gravity # direction; 0.0
Gravity " direction: |-1.0
Gravity £ direction: 0.0

Lastly, select Criterion temp tab and enter 1 to Criterion temp.
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3 intvdata

L 5 K2

Contral | Gravity  Criterion temp ]

Criterion temp: [1]

Accept Cloze

After the setting interval data, click the Accept data button to make the defined step data valid. Click the Close button to
complete the Interval dialog box.

4.4 Meshing Generation

Select the following from the Top Menu.

Meshing->Structured->Volumes
Select volume 1, volume 2, and volume 3.

Enter 40 for the number of partitions on line 11, and click the OK button to select line 11. All lines are selected in the
same manner as line 11. After the selection, click the Esc key to complete the line selection. In the same manner, set 8
partitions for line 17. Click the Esc key or click the OK button to close the dialog box.

Then, select the following from the Top Menu.

Meshing->Generate

The Enter value window dialog box shown below will display. Use the default value for the element size and click OK. A
square shaped meshing will be automatically generated when this is done.

With regard to details of meshing generation, refer to the section 3.4.3.

4.5 Executing Analysis
Select the following from the Top Menu and click start button.

Calculate->Calculate window ...

With regard to details of executing analysis, refer to the section 3.6.

4.6 Postprocessing

After the analysis is complete, enter the GID postprocess mode. To enter the GiD postprocess mode by GiD menu,
select the following from the Top Menu.

Files — Postprocess

To display a distribution of volume fraction, Select the following from the Top Menu.
View Results->Contour Fill>Scalar2
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A volume fraction distribution shown below will display.

Scalar2

1
I 035652
07rre
- D567
- 055556
- 044444
- 01333353
D2e22?
01111
0

step 20
Contour Fill of Scalar?.
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5. GiD-CCFD Analysis Interface

Depending on the analysis type, all data handled in the Data menu in the GiD changes in correspondence to all the
different analysis types. This allows you to select the installed analysis types. When selecting a new analysis type,
already selected or defined material and condition information as well as other data parameters will be lost.

The Data menu in the GiD and CCFD interface is described below.

Select the following from the Top Menu.
Data->Problem type->FINAS->CFD

5.1 Problem data (analysis data)

Problem data is related to all data that are the basic items of an analysis. This is not related to shape elements. This
data can also be entered before or after meshing generation.

Select the following from the Top Menu.
Data->Problem data

The Problem data dialog box will display. Input for the Problem data dialog box is accepted by pressing the Accept
button to initially accept the data.

T4 proble mdata

General ] Restart ] anitaring point ] Scalar ] VaF ] Coupling

TITLE | Title_name
Type of problem; UWSTEADY —

Turb model: MO —

Sweep:l'lﬂi
Relax factor: 0.8
Relax factar P: llﬂi
Scheme(0.0-1.00: 0.0

TITLE: Allows you to set a title for the current analysis case. The character string is a maximum of 80 alphanumeric
characters.

Type of problem: Analysis type 1. Specify time management here. Select either STEADY, UNSTEADY or EXPLICIT.

Turb model: Analysis type 2. Selects turbulent model. You can select the turbulent models shown below.
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+ NO: Laminar model
* k-¢: Standard k-¢ model
+ LES: LES model
Sweep: Specifies the number of sweeps. The meaning differs depending on the model specified in Type of problem.
+ STEADY: Specifies the total number of sweeps until the analysis completes.
+ UNSTEADY: Specifies the number of sweeps during one time step.
« EXPLICIT: It is not necessary to set it.
Relax factor: Sets the relax factor. The meaning differs depending on the model specified in Type of problem.
+ STEADY or UNSTEADY: Setting this value to a suitable value allows you to control excessive

variations in variables. Variables become more difficult to vary as the value
becomes smaller.

« EXPLICIT: It is not necessary to set it.
Relax factor P: Sets the relax factor for pressure or Courant number.
+- STEADY or UNSTEADY: Setting this value to a suitable value allows you to control excessive
variations in pressure. Pressure becomes more difficult to vary as the

value becomes smaller.

« EXPLICIT: Means Courant number. Setting smaller Courant number increases numerical stability and
calculation time.

Scheme[0 1]: Sets the windward coefficient. When set to 0, it is first order upwind difference and when setto 1, itis a
second order central difference. If you set the value from 0 to 1, they will form a mixture. (Refer to Theory Manual 3.3.2.)
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General  Festart l Monitoring paint | Sealar | YOF | Coupling

[ Restart:

Restart File: |restart

Cloze

Restart: r Specifies an analysis using a restart. Selecting this check box allows you to restart from a specified file.

Restart File: Specifies the input file name for the restart. Valid when the Restart check box is selected.
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General | Restat  Monitoring point l Scalar | VOF | Coupling

konitoring Point: |0

Cloze

Monitoring Point: Specifies the cell number for monitoring point display. The values of each variable at points specified
by monitoring points are displayed on the screen in order to know the convergence state during calculations.
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General ] Restart ] Monitoring point— Scalar l YaOF ] Coupling

[ TEMPERA:
[ Scalar2:
[ Scalar3:
[ Scalard:
[ Scalars:

Cloze

TEMPERA: r Specifies temperature calculations. Selecting this check box will perform temperature calculations.

Scalar2: r Specifies calculations of scalar data 2. Selecting this check box will perform calculations of scalar data 2.
Scalar3: r Specifies calculations of scalar data 3. Selecting this check box will perform calculations of scalar data 3.
Scalar4: r Specifies calculations of scalar data 4. Selecting this check box will perform calculations of scalar data 4.

Scalar5: r Specifies calculations of scalar data 5. Selecting this check box will perform calculations of scalar data 5.
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General ] Restart ] Muanitaring paint ] Scalar  YOF ] Coupling

[ UsewOF

number af phase: |2
Courant number: 0.3
phazeZ WISCOSITY: |1.8e-05
phaze? TERMAL DIFF COEF: (1.0
phasez DEMSITY: |1.0
phaze? EXCO: |0.0

Cloze

Use VOF: r Specifies an analysis using VOF method. Selecting this check box allows you to use VOF method for
free surface flow.

Number of phase: Specifies the number of phases. In the current version the number of phases is fixed at 2.
Courant number: Specifies Courant number for conservation equation of volume fraction.

Phase2 VISCOSITY: Specifies viscosity of secondary phase.

Phase2 THERMAL DIFF COEFF: Specifies thermal diffusion of secondary phase.

Phase2 DENSITY: Specifies density of secondary phase.

Phase2 EXCO: Specifies thermal expansion rate of secondary phase.
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General ] Restart ] Fonitoring point ] Scalar ] wOF  Coupling
[+ Usze Coupling
Time Table  start end step & |
n [1nn npns ==
< ]
3 X
Accept Cloze

Use Coupling: r Specifies an analysis coupling with PFC3D. Selecting this check box allows you to execute CFD-
DEM coupling analysis.

Time Table: Specifies time for coupling problem.
- start: start time of coupling.
- end :end time of coupling

- step: time step interval of data exchange between CCFD and PFC3D.
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5.2 Initial Conditions

Sets initial conditions during CFD analysis in Initial dialog.
Select the following from the Top Menu.

Data->Conditions=>Initial

Ay

Iritial alue - i)

Imitial % alue [Pres]; 0.0
[ritial W alue [x] 0.0
Irmitial W alue [Wy]: (0.0
[ritial %alue 2] |0.0

[mitial % alue [Temp]: (0.0
Imitial * alue [Fe]: (1.0E-10
[ritial % alue [Ep]: |1.0E-10

Initial % alue [Scalarz]: (0.0
Iritial Y alue [Scalar3]; (0.0
Iritial % alue [Scalard]: (0.0
Imitial W alue [Scalarb]: (0.0

Az=ign Entities Diraw Unaszign

Cloze

Initial Value [Pres]: Enter the initial value for the pressure of the calculation area.

Initial Value [Vx]: Enter the initial value for velocity in X-direction of the calculation area.
Initial Value [Vy]: Enter the initial value for velocity in Y-direction of the calculation area.
Initial Value [Vz]: Enter the initial value for velocity in Z-direction of the calculation area.

Initial Value [Temp]: Enter the initial value for the temperature of the calculation area when performing temperature
calculations. This value is ignored when temperature calculations are not performed.

Initial Value [Ke]: Enter the initial value for turbulent energy of the calculation area when using k-¢ model in the turbulent
model. This value is ignored when turbulent flow calculations are not performed.

Initial Value [Ep]: Enter the initial value for viscous dissipation of the calculation area when using k-¢ model in turbulent
model. This value is ignored when turbulent flow calculations are not performed.

Initial Value [Scalar2-5]: Enter the initial value for Scalar 2-5 of the calculation area when performing scalar calculations.
This value is ignored when scalar calculations are not performed.

5.21 Assigning initial conditions

Assign: Assigns initial conditions. If you press the Assign button, a selection list of geometry to which initial conditions
are assigned will appear. Select the geometry you want to assign to assign the initial conditions.
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Entities: Displays the list of the assigned initial conditions.

Draw: Displays the assigned initial conditions. If you press the Draw button, two lists will appear.
+ All initial displays all initial conditions
+ (Condition name) displays name of conditions which is selected by list box.
+ Colors divides the initial conditions selected in the list box into colors and then displays them.
- Field’s value displays the value of the initial conditions.
« Field’s color divides the initial conditions by selected item then displays them.

il

Iritial alue - i)

Iritial % alue [Prez]: (0.0

I nitial % alue [v]; |0.0

[ nitial W alue My]: | 0.0

|nitial % alue [2]: | 0.0

I nitial % alue [Temp]: (0.0
[nitial %alue [Fe]: |1.0E-10
[ritial % alue [Ep]: | 1.0E-10

Initial W alue [Secalar]: (0.0

I nitial % alue [Scalar3): |0.0

|nitial W alue [Scalard): (0.0

Initial W alue [Scalars): (0.0

Azzign Entities Diraw Unazzign
C .-’-‘-.I! initial
Imitial- alue
Colors
Al conditions  #
Field's value ¥
Field's color ¥

Unassign: Cancels a material. If you press the Unassign button, three lists will appear.

- Initial-value Entities: If you press the Entities list, a selection list of geometry to cancel will appear. Select the
geometry you want to cancel to cancel the initial conditions.

« All Initial-value: Cancels all initial conditions which is selected by list box.
+ All Initial: Cancels all initial conditions.

+ All Conditions: Cancels all initial and boundary conditions.
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Eil

Initial alue

Initial % alue [Prez]: (0.0
[nitial W alue [x]: 0.0
[nitial W alue My]: 0.0
I nitial % alue [Wvz]: 0.0

[nitial " alue [Temp]: (0.0
Imitial % alue [Fe]: (1.0E-10
[nitial “alue [Ep]: |1.0E-10

Initial ' alue [Scalar]: (0.0
I nitial % alue [Scalar3): (0.0
|nitial “alue [Scalard]: (0.0
Initial W alue [Scalars): (0.0

Azzign Entities Diraw

...............................

Cloze

Unazzign

Imitial alue Entities
Al Iritial- alue

Al [nitial

All conditionz
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5.3 Materials

Sets material data for the analysis area. The Conditions that can be set are both shapes and meshing. We recommend
setting to shape however. If set to shape, the material data automatically be reflected in the meshing. When set to
meshing, the material data will be lost by regeneration of meshing.

Caution: If meshing is already generated, the meshing must be generated again for all changes to the set material, or
material settings must be applied directly to the meshing.

Select the following from the Top Menu.

Data->Materials

Materials @
[WATER EA Y

DEMSITY [333.23
VISCOSITY |1.004E-2

TERMAL DIFF COEF |1.423E-4

ExCO|1.18E-4

Azzign Qraw| unassign| Import/E sport

Cloze

5.3.1 Defining Materials

Material list

||WMEH g Select materials already defined from the list box. Materials not listed in this list box can be
defined using the new material button.

New material data

\QI You can create new material data using this button. Newly created material data is copied with the same structure
as the material selected immediately before.

Delete material data

‘Zl You can delete the currently displayed material data using this button.

Update material data

|@I The currently displayed material data is reflected in the project using this button.
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Enter physical property values for the following four items.

DENCITY: Enter the material density.

VISCOCITY: Enter the viscosity coefficient of a material.

THERMAL DIFF COEF: Enter the thermal diffusion coefficient.

EXCO: Enter the thermal expansion rate.

5.3.2 Assigning Material

Assign: Assigns materials. If you press the Assign button, a selection list of geometry to which materials are assigned

will appear. Select the geometry you want to assign to assign the materials.

Materials X

['wATER

2 H O

DEMSITY [993.23
YISCOSITY [1.004E-3

TERMAL DIFF COEF [1.428E-4

ExCO|1.18E-4

Agzign Qraw| Qnassign| Import/E xport |
Foints
' Cloze
Liresz
Surfaces

Walumes
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Draw: Displays the assigned materials. If you press the Draw button, two lists will appear.
+ This material displays the currently selected material.
+ All material displays all materials.

fWATER E3 @| | &2

DEMSITY [998.23
YISCOSITY |1.004E-3
TERMAL DIFF COEF [1.422E-4
EXCO|1.18E-4

gssign| Qraw| Qnassign| [miport/E xport |

Thiz material ‘

All materialz

Unassign: Cancels a material. If you press the Unassign button, three lists will appear.

« Entities: If you press the Entities list, a selection list of geometry to cancel will appear. Select the geometry you
want to cancel to cancel the material.

+ All material name: Cancels all materials of a material name.

« All Materials: Cancels all materials.

fWATER X O g2

DEMSITY [333.23
VISCOSITY |1.004E-32
TERMaAL DIFF COEF |1.428E-4
ExCO|1.18E-4

gssign| Qraw| Qnassign| Import/Export |

Entities Paintz
Al matenal wWATER Lines

All M atenals

Surfaces

Yalumes
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Import/Export: Reads / writes material data. If you press the Import/Export button, a selection dialog box of material
database files will appear. Specify the material database file. The file extension is ‘.mat.’

Directany: C:\Program FileshGIDAGID 7. 24problemtypes\CFD.gid  — | Q

CFD . mat

1 2]
Fil= narme: I Ok
Files of lype:  Materials [*.mat] — | Lancel

When a file is specified, the Import/Export screen will appear. The column on the right is material data existing in a
material database file, and the left side is material data that can be used at present. Clicking the material name and
pressing the arrow allows you to copy from the material database file to the current data or from the current data to the
material database file. You can also copy all the data by pressing the arrow twice.

Import/Export material X
The current project material: and the databaze
materialz can be managed in thiz window,
Current materials Databaze materials
Alurnirrm - ’ STEEL -
STEEL — |alR
AlR WATER
WaTER —»
‘_
r Nk
= | = |T Fename | Delete |
Accept data | Cloze | Idpdate external database |
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5.4 Boundary Conditions

Sets boundary conditions during CFD analysis in Conditions.

Conditions can be set to both shapes and meshing although we recommend setting to shapes. When set to shapes, the
displacement boundary conditions will be reflected in the meshing. When set to meshing, the displacement boundary
conditions will be lost during meshing regeneration.

Caution: When meshing has already been generated, the meshing must be generated once again in order to move the
new conditions to the meshing when changing the condition settings. If the meshing is not regenerated, a warning will
sound when executing the analysis.

Select the following from the Top Menu.

Data->Conditions->Boundary

Conditions

FI<EDVELOCITY g ﬂ

HAalue (0.0
Y4 alue (0.0
£ alue (0.0

Azzign | Entities| Qraw| Qnassign|

Close |

Use the ﬁ@ buttons to select boundary conditions given to surfaces or volumes, respectively.

541 Assign (assigning boundary conditions)

The assign button assigns established boundary conditions to geometry or meshing. First, select the boundary conditions
you want to assign from the list box, and then specify geometry or meshing after entering a numeric value corresponding
to each. The following boundary conditions can be set from the list box for surfaces or volumes.

(a) Boundary conditions set to surface

e FIXED-VELOCITY: Sets the flow rate. Enter each component of the X, Y, and Z
direction in each X-Value, Y-Value, Z-Value. Surfaces without a flow rate
specified for the boundary condition are handled as symmetrical barriers.

e FIXED-PRESSURE: Sets the pressure. Enter the pressure to be set in PRESSURE.

e FIXED-TEMPERATURE: Sets the temperature. Enter the temperature to be set in
TEMPERATURE .

1. HEAT-FLUX: Sets the heat flux. Enter the heat flux to be set in HEAT-FLUX.

4 7 C TCMW
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HEAT-TRANSFER: Sets the heat transfer coefficient and fixes the temperature. Set
the heat transfer coefficient in COEFFICIENT and the temperature in TEMPERATURE.

FIXED-SCALAR2: Set scalar data 2 as a fixed value. Enter the value to be set in
FIXED-SCALAR2.

SC2-FLUX: Sets the flux of scalar data 2. Enter the flux to be set in SC2-FLUX.

SC2-TRANSFER: Enter the transfer coefficient of scalar data 2. Enter the transfer
coefficient in COEFFICIENT and the value of scalar data 2 in SC2-TRANSFER.

FIXED-SCALAR3: Sets scalar data 3 as a fixed value. Enter the value to be set in
FIXED-SCALARS3.

SC3-FLUX: Sets the flux of scalar data 3. Enter the flux to be set in SC3-FLUX.

SC3-TRANSFER: Enter the transfer coefficient of scalar data 3. Enter the transfer
coefficient in COEFFICIENT and the value of scalar data 3 in SC3-TRANSFER.

FIXED-SCALAR4: Sets scalar data 4 as a fixed value. Enter the value to be set in
FIXED-SCALARA4.

SC4-FLUX: Sets the flux of scalar data 4. Enter the flux to be set in SC4-FLUX.

SC4-TRANSFER: Enter the transfer coefficient of scalar data 4. Enter the transfer
coefficient in COEFFICIENT and the value of scalar data 4 in SC4-TRANSFER.

FIXED-SCALARS: Sets scalar data 5 as a fixed value. Enter the value to be set in
FIXED-SCALARS.

SC5-FLUX: Sets the flux of scalar data 5. Enter the flux to be set in SC5-FLUX.

SC5-TRANSFER: Enter the transfer coefficient of scalar data 5. Enter the transfer
coefficient in COEFFICIENT and the value of scalar data 5 in SC5-TRANSFER.

(b) Boundary conditions set to volume
SOLID: Specifies solid portions. Enter the velocity in FIXED VELOCITY.

HEAT-SOURCE: Sets calorific value. Enter the calorific value in HEAT SOURCE.
SC2-SOURCE: Sets the source of scalar data 2. Enter the generated amount in SC2
SOURCE.

SC3-SOURCE: Sets the source of scalar data 3. Enter the generated amount in SC3
SOURCE.

SC4-SOURCE: Sets the source of scalar data 4. Enter the generated amount in SC4
SOURCE.

SC5-SOURCE: Sets the source of scalar data 5. Enter the generated amount in SC5
SOURCE.

When setting conditions, all figure relationship functions (zoom, rotate, etc) can be used. To apply the settings, press the
Esc key or click the Finish button in the Conditions screen.

Caution: When meshing has already been generated, the meshing must be generated once again to reflect any changes
in the condition settings.

48 CTC




GiD CFD

5.4.2 Draw (displaying boundary conditions)

Displays boundary conditions set to geometry or meshing. Five menus will appear when the Draw button is pressed.

e This (condition name) displays the boundary conditions selected in the list box (condition name).
e Colors divides the boundary conditions selected in the list box into colors and then displays them.

Conditions

Fl<EDAELOCITY g ﬂ

#Malue (0.0
Y4 alue (0.0
S alue (0.0

Agzign | Entities| Qraw| Qnassign|

Thiz FI<EDELOCITY
Colors

All conditions r
Figld's walue r
Field's calar r
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e All Conditions has another three sub-menus.

Exclude local axes: Displays boundary conditions except for the boundary conditions set to local axes when
using local axes.

Only local axes: Displays only the boundary conditions set to local axes when using local axes.

Include local axes: Displays boundary conditions including the boundary conditions set to local axes when using
normal boundary conditions and local axes.

Conditions

Fl<EDAELOCITY g ﬂ

#Malue (0.0
Y4 alue (0.0
S alue (0.0

Azsign | Entities| Qraw| Qnassign|

Thiz FI<EDELOCITY

Colors |

Al conditions Exclude local axes
Figld's value ¥ Only local aves
Field's calar b Include local ares
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e Field’s value displays the values of the boundary conditions selected in the list box. The sub-menu where you
select the value to be displayed in response to the boundary condition will appear. For example, the three sub-
menus for the values shown below will appear for FIXED-VELOCITY and the values of the boundary conditions
in the X, Y, and Z directions will display.

X-Value
Y-Value
Z-Value
For FIXED PRESSURE however, the sub-menu will only be PRESSURE.

Conditions

FI<EDAELOCITY g @

#4alue (0.0
4 alue (0.0
£ alue (0.0

Azsign | Entities| Qraw| unassign|

Thiz FI<ED-ELOCITY
Colars
»

Al conditions

Field's walue HAlalue
Field's calar K Y Nalue
M\ alue
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e Field’s color divides the values of the boundary conditions selected in the list box into colors and displays them.

The sub-menu where you select the value to be displayed in response to the boundary condition will appear.
For example, the three sub-menus for the values shown below will appear for FIXED-VELOCITY and the
values of the boundary conditions in the X, Y, and Z directions will be divided into colors and display.

X-Value

Y-Value

Z-Value
For FIXED PRESSURE however, the sub-menu will only be PRESSURE.

Conditions

FI<=ED-ELOCITY g ﬂ

#Aalue 1
W alue 0.0
£ alue (0.0

Azzign | Entities| Qraw| unassign|

Thiz FI<EDAELOCITY

Colors

All conditions r

Figld's walue r

Field's caolar #A alie
T4 alue
4 alue
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54.3 Unassign (canceling boundary condition settings)

Cancels set boundary conditions. Three menus will appear when the Draw button is pressed.

e (condition name) Entities: Cancels the boundary conditions selected in the list box (condition name) by selecting
geometry or meshing.

e All (condition name): Cancels the boundary conditions selected in the list box (condition name) for all geometry
or meshing set by these boundary conditions.

e All Conditions: Cancels all boundary conditions.

Conditions

FI<ED-ELOCITY g ﬂ
A alue I'Ii
A alue 0.0
W alue llillili

Azzign | Entities| Qraw| Qnassign|

Clos FI=EDAELOCITY Entities
——  AlIFREDVELOCITY
All Conditions
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5.5 Interval Data

Edits interval data. Use Data-> Interval Data.
This data can also be entered before or after meshing generation.
Select the following from the Top Menu.

Data-> Interval Data

The sub-menu shown below will appear.

Mumber of Steps: | 100000
Time step increment; |0.005
Step freq. post process: (10

L = &

Cortrol | Gravity | Criterion temp |

fccept i Cloze

Number of Steps: Enter the number of calculation steps for unsteady calculations. Enter 1 for steady calculations.

Time step increment: Enter the time step for unsteady calculations. The time step multiplied by the number of

calculation steps will be the total calculation time. Enter 1 for steady calculations.

Step freq. Post process: Specify the file output interval of calculation results during unsteady calculations. If 1, it

outputs files every step. If 10, it outputs files every 10 steps.
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i Interval Data

1 = v o

Control - Gravity l Criterion temp |

Grawity Walue: |0.0
Gravity ¥ direction: |0.0
Gravity " direction: |0.0
Gravity £ direction: |-1.0

Cloze

Gravity Value: Enter a value for gravity acceleration. Enter the direction of acceleration as a vector componentin X, Y, Z
below.

Gravity X direction: Enter X-direction component of gravity acceleration.
Gravity Y direction: Enter Y-direction component of gravity acceleration.

Gravity Z direction: Enter Z-direction component of gravity acceleration.
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i Interval Data

i 2l k2

Contral | Gravity  Criterion temp |

Criterion temp: |EI.EI

Cloze

Criterion temp: Enter thermal expansion reference temperature when performing temperature calculations (Boussinesq
approximation). Use for buoyancy calculations. This value is ignored when temperature calculations are not performed.
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6. How to use User Defined Function
6.1 Outline

Here, how to define User Defined Functions for boundary conditions and material properties is explained. Using the User
Defined Function, it is available to use temperature dependent material data, time dependent inlet velocity, etc. User
Defined Function must be written in C++.

6.1.1 Limitation
User Defined Function is available for boundary conditions (section 6.5) and material properties (section 6.4).

6.1.2 Requirement

For creating original User Defined Function or modifying existing User Defined Function, the following development
environment must be required.

Microsoft Visual C++.NET 2003 or higher  (Standard or higher)

6.2 Specifying User Defined Function

6.2.1 Boundary Conditions
Select the following from the Top Menu.

Data->conditions>boundary

The Boundary dialog box shown below will display. Select boundary condition name from list box and enter the name of
User Defined Function to setting column. In the following example, X-Value of FIXED-VELOCITY is set to User Defined
Function named as “userX”.

Then click the Assign button to assign the boundary conditions to the geometry or meshing.

Boundary

FIXED-VELOCITY | @ i
Lizers

e
T
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6.2.2 Material data

Select the following from the Top Menu.
Data->Materials

The Materials dialog box shown below will display. Enter the name of User Defined Function to setting column. In the
following example, THERMAL DIFF COEF is set to User Defined Function named as “userT".

Then click the Assign button to assign the boundary conditions to the geometry or meshing.

Tis Materials E'
WATER ~BOXK D
DENSITY [398.23

YISCOSITY |1.004E-3
TERMAL DIFF COEF |uzerT
EXCO|1.18E-4

Azsign Diraw Unazzign Exchange

Cloze

6.3 How to build Dynamic Link Library

6.3.1 Preparation

If you create new User Defined Functions, you must prepare development environment for building User Defined
Functions.

A template of User Defined Function is stored in the directory as follows.

C:\Program Files\GiD [Ver.No.]\Problemtypes\CFD.gid\UserPlugin ([Ver.No.] means GiD version number.)

Copy the directory shown above to working directory. In the example shown in below, a template directory is copied to
“finas_cfd_test.gid” directory.
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% UserPlugin

eI REE) H/TN) BRICAUM) = )L(T) A gLFH
Q= - © - ¥| LO8& i |-
T L2 D | C¥work¥FINAS GFD¥finas_cfd_testgid¥User Plugin
A w | BE - I 4
I3 fin_testeid LI ggzll:nug
= 5 finas_ofd_testeid = eace
=R =P luzin : SrC .
) Debue getDatalib 4
I5) Release ] UzerPluginnch 5
) =ro [om UserPlugin.zln
I FINAS_CGFD Werl.2 _\AUSEVPME!n.sun .
I5) finas_test 1 LlserF‘Iugln.vcprDj
I fludl eid

6.3.2 Making source file (UserPlugin.cpp)

UserPlugin.cpp (template of User Defined Function source file) is stored in the source directory “src” under the
UserPlugin directory. User Defined Functions must be described in UserPlugin.cpp.

Start Microsoft Visual Studio and open the solution file (UserPlugin.sln) stored in the UserPlugin directory. Once the
solution file is opened, open UserPlugin.cpp. Contents of UserPlugin.cpp is as follows.

// 3\
// CFDPlugin.h: CFDPlugin ¥ S AMDA 2 —T 4 X

//
#include <windows. h>
#include <cmath> This part must not be
#include “CFDPlugin.h” modified.

#tinclude “getData.h”
#tdefine DLL_BOUND_DATA( func_name ) extern “C” double _ declspec(dllexport)

using namespace CRGC_CFD; J

// A—HY—EZEHDETE
/] HrTI-FERE
DLL_BOUND_DATA ( userSource )
{

User Defined Function must be defined here.

User Defined Function must be defined within parentheses below a header DLL_BOUND_DATA( ... ) . And you need to
write a name of User Defined Function inside parentheses. In the list shown above, the name of User Defined Function
is defined as “userSource”.

The list shown below is an example of User Defined Function. This User Defined Function gives heat source depending
on coordinates of each cell center.

Variables defined in CCFD (ex. cell center coordinate, velocity, pressure, etc.) are available to use in User Defined
Functions. You need to call “Get Functions” to get variables in CCFD. Summary of the Get Functions is shown in the
section 6.3.4.

In the list shown below, function named as userSource call data.GetCellCenter(iCell,si,sj,sk) to get coordinates of cell
center. If data.GetCellCenter(iCell,si,sj,sk) is called, x, y and z coordinate of the cell center are stored to si, sj and sk
respectively. Then heat source is evaluate using si, sj, sk.
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DLL_BOUND_DATA( userSource )

{
double si,sj,sk;
double Source;
double r1,r2;
//Cellsh i EERZ D ER TG
data.GetCellCenter(iCell,si,sj,sk);
ri = 1.0 - sgrt(pow((si-2.0),2)+pow((sj-0.0),2));
r2 = 1.0 - sqrt(pow((si-8.0),2)+pow((sj-0.0),2));
if(r1>=0)
Source = r1*1000.0;
Yelse if(r2>=0){
Source = r2*1000.0;
Yelse{
Source = 0.0;
return ( Source );
¥

6.3.3 Building Dynamic Link Library

Select the following from the Top Menu of Visual Studio.
Build-> Build UserPlugin

Once build process complete, UserPlugin.dll will be created in the GiD project directory.
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6.3.4  Summary of “Get Functions”
Geometry
name argument function return values
o Get coordinates | Sx . x coordinate of the center of the
const int iCell of the center of | cell surface
const int iSurf the cell surface. | g, .y coordinate of the center of the
GetSurfaceCenter double &Sx cell surface
double &Sy Sz :  z coordinate of the center of the
double &Sz cell surface
Get area of the
const int iCell cell surface.
GetSurfaceArea const int iSurf Area Area of the cell surface
double &Area
finticel Get the cell | Volume cell volume
constintiCe volume
GetCellVol
etelivolume double &Volume
L Get coordinates | Cx x coordinate of the cell center
const int iCell of the center of -
double &Cx the cell Cy x coordinate of the cell center
GetCellCenter double &Cy Cz x coordinate of the cell center
double &Cz

Cell surface (4 surfaces in tetrahedra)

Center of the cell surface
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Analysis data

name

argument

function

return values

getTime

none

Get simulation time.

Return value : time

GetPress

const int iCell
const int iSurf
double &Press

Get pressure.

Press pressure

GetVeloXYZ

const int iCell

const int iSurf
double &vX
double &vY
double &vZ

Get velocity vector.

vX : xvelocity
vY :y velocity
vZ : zvelocity

GetScalar

const int iCell
const int iSurf
int ScalarType
double &Scalar

Get scalar value.

Scalar Scalar value'

GetScalarSolid

const int iCell
const int iSurf
int ScalarType
double &Scalar

Get scalar value in
solid cell.

Scalar Scalar value'

GetKe

const int iCell
const int iSurf
double &Ke

Get turbulent kinetic
energy.

Ke : turbulent kinetic energy

GetEp

const int iCell
const int iSurf
double &Ep

Get dispersion rate.

Ep . dispersion rate

GetPorosity

const int iCell
const int iSurf

double &Porosity

Get porosity.

Porosity Porosity

If fluid cell is connected to solid cell :

+ GetScalar(iCell,iSurf,ScalarType,Scalar)

—Scalar value at the fluid cell (Point A) is stored in “Scalar”
+ GetScalarSolid(iCell,iSurf,ScalarType,Scalar)

—Scalar value at the solid cell (Point B) is stored in “Scalar”

! ScalarType=0 : Temperature, ScalarType=1~4: Scalar2~5
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Material data

name argument function return values
const int iCell Get viscosity. Viscosity viscosity
GetViscosity const int iSurf
double &Viscosity
const int iCell Get density. Rho density
GetRho const int iSurf
double &Rho
Get density in solid cell | Rho density
const int iCell
GetRhoSolid const int iSurf
double &Rho
o Get thermal diffusivity ThermDiff thermal
const int iCell e
e L diffusivity
GetThermalDiffusivity const int iSurf
double &ThermDiff
Get thermal diffusivity in | ThermDiff thermal
const int iCell solid cell. diffusivity
GetThermalDiffusivitySolid const int iSurf
double &ThermDiff
Get thermal expansion | ThermExp thermal

GetThermalExpansion

const int iCell
const int iSurf
double &ThermExp

ratio.

expansion ratio
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7. Data File Format

Here is the formats of data files used by the CCFD are described. Data beyond what is described here cannot be

changed by users.

7.1 List of Files Used

The CCFD uses the following seven types of files. These files are generated by the GiD although the user can also

generate them.

Input files

Init.dat: File that describes the parameters to control the execution of CCFD.

Input.ini: File that describes the initial condition data for calculations.

Node.dat: File that describes the node data for calculation areas.

Elem.dat: File that describes the element data for calculation areas.

Bound.dat: File that describes the boundary conditions for calculation areas.

Output files

Result: Files that store calculation results of the final steps of steady calculations and unsteady calculations.

Result#.out: Files that store results during calculations when unsteady calculations are being performed. Outputs
calculation results for every step specified in Step freq. Post process of section 4.2 Interval Data. Enter the number of
steps in #. The calculation results of the final step are the same as Result.

7.2 File Formats

7.21 Init.dat

Bold words are values set in the GiD menu.

Total Total number Number of Slip
number of of elements boundary
nodes

Number of Number of
velocity pressure
boundary boundary
elements elements

| Number of solid boundary elements

[Problem data]
Monitoring Point

Number of scalar variables

Temperature Dirichlet

Number of boundary
elements *1

Neumann temperature

Number of boundary
elements *1

Heat transfer coefficient
Number of elements  *1

Heat source

Number of boundary
elements *1

Scalar2 Dirichlet

Number of boundary
elements *1

Neumann Scalar2

Number of boundary
elements *1

Scalar2 transfer
coefficient

Number of elements  *1

Scalar2 source

Number of boundary
elements *1

Scalar3 Dirichlet

Number of boundary
elements *1

Neumann Scalar3

Number of boundary
elements *1

Scalar3 transfer
coefficient

Number of elements  *1

Scalar3 source

Number of boundary
elements *1

Scalar# Dirichlet
Number of boundary

Neumann Scalar#

Scalar# transfer
coefficient

Scalar# source
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elements *1 Number of boundary Number of elements  *1 | Number of boundary

elements *1 elements *1
[Problem Data] [Problem Datal] [Interval Data] [Interval Data] [Problem Datal [Problem Data]

Relax factor

Relax factor P

Number of Steps x
Time step increment

Time step increment

Scheme

Sweep

[Interval Data] [Problem Data] Analysis Type1 *2 Analysis Type2 *2
Step freq. Post process | Restart
(On =1,0ff=0)
[Interval Data] [Interval Data] [Interval Data] [Interval Data] [Interval Data]

Gravity X direction

Gravity Y direction

Gravity Z direction

Gravity Value

Criterion temp

[Problem Data]
Restart File

*1: The number of data will change depending on the number of scalar variables. When the number of scalar variables is

0, this portion wil

| become zero.

*2: Combinations of analysis types 1 and 2 of the Problem Data menu become the following values.

Analysis type 1 Analysis type 2 Analysis Type 1 Analysis Type 2 Analysis Type
STEADY NO 0 0 Steady
STEADY ke 0 1 Steady+k-¢
STEADY LES 0 2 Steady+LES
USTEADY NO 1 0 Unsteady
USTEADY ke 1 1 Unsteady+k-¢
USTEADY LES 1 2 Unsteady+LES
7.2.2 Input.ini
| 0 | 0 0 0 Analysis Type1 *1 Analysis Type2 *1 |
| Element ID1 |
Mass flow rate of | Mass flow rate of | Mass flow rate of | Mass flow rate of | Mass flow rate of | Mass flow rate of
surface 1 of surface 2 of surface 3 of surface 4 of surface 5 of surface 6 of
element 1 element 1 element 1 element 1 element1 *2 element1 *2
Prev Press Vx Vy Vz k e Temp Scalar2 Scalar# | MuTau
Press
Repeated number of elements on and after the second line
Prev Press: Pressure before step 1
Press: Pressure
Vx: X-direction velocity
Vy: Y-direction velocity
Vz: Z-direction velocity
k: Turbulent energy
e: Viscous dissipation rate
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Temp: Temperature
Scalar2: Scalar 2
Scalar#: Scalar #
MuTau: Turbulent flow viscosity coefficient
*1: Value identical to init.dat.
*2: Enter 0 when element shape is a four-sided body.
723 Node.dat
Total number of Node ID
nodes maximum value
| Node ID1 | X coordinate value | y coordinate value | z coordinate value |
| Node ID2 | X coordinate value | y coordinate value | z coordinate value |
Total repeated number of nodes on and after the second line 2
7.24 Elem.dat
Total number of Element ID
elements maximum value
Tetra element
| Element Type *1
Element Node 1D1 Node ID2 Node ID3 Node ID4 Viscosity Thermal Density Thermal
ID diffusion expansion
coefficient rate
Hexa element
Element Type *1
Element | Node | Node | Node | Node | Node | Node | Node | Node | Viscosity | Thermal Density | Thermal
ID ID1 ID2 ID3 ID4 ID5 ID6 ID7 ID8 diffusion expansion
coefficient rate

o]

Repeated number of elements on and after the second line

*1: Element Type=6 Tetra element, Element Type=8 Hexa element
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7.2.5

Number of slip

Bound.dat

boundary
elements

Tetra element

Element Type

Element ID | Surface 1 Surface 2 Surface 3 Surface 4
value value value value

Hexa element

Element Type

Element ID | Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
value value value value value value

Repeated number of slip barrier elements

Value: x-direction slip = 1, y-direction slip = 2, z-direction slip = 3
xy-direction slip = 12, xz-direction slip = 13, yz-direction slip = 23, xyz-direction slip = 123

Number of

velocity boundary

elements

Tetra element

Element Type

Element
ID x-d

Fla

Surface 1

irection
g

Surface 1
y-direction
Flag

Surface 1
z-direction
Flag

Flag

Surface 2
x-direction

Flag

Surface 2
y-direction

Surface 2
z-direction
Flag

Surfac

Flag

x-direction

e 3

Flag

Surface 3
y-direction

Surface 3
z-direction
Flag

Surface 4
x-direction
Flag

Surface 4

y-direction
Flag

Surface 4
z-direction
Flag

Surface 1
x-direction
value

Surface 1

y-direction
value

value

Surface 1
z-direction

value

Surface 2
x-direction

Surface 2

y-direction
value

Surface 2
z-direction
value

Surface 3
x-direction
value

Surface 3
y-direction
value

Surface 3
z-direction
value

Surface 4
x-direction
value

Surface 4

y-direction
value

Surface 4
z-direction
value

Hexa element

Element Type

Element ID

Surface 1
x-direction
Flag

Surface 1

Flag

y-direction

Surface

Flag

z-direction

1 Surface 2
x-direction

Flag

Flag

Surface 2
y-direction

Flag

Surface 2
z-direction

x-di

Surface 3

Flag

S
rection

y-direction
Flag

urface 3

Surface 3
z-direction
Flag

Surface 4
x-direction
Flag

Surface 4

y-direction
Flag

Surface 4
z-direction
Flag

Surface 5
x-direction
Flag

Flag

Surface 5
y-direction

Flag

Surface 5
z-direction

Flag

Surface 6
x-direction

Flag

Surface 6
y-direction

Surface 6
z-direction
Flag
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Surface 1 Surface 1 Surface 1 Surface 2 Surface 2 Surface 2
x-direction y-direction z-direction x-direction y-direction z-direction
value value value value value value
Surface 3 Surface 3 Surface 3 Surface 4 Surface 4 Surface 4
x-direction y-direction z-direction x-direction y-direction z-direction
value value value value value value
Surface 5 Surface 5 Surface 5 Surface 6 Surface 6 Surface 6
x-direction y-direction z-direction x-direction | y-direction z-direction
value value value value value value
Repeated number of velocity boundary elements
Flag: Flag=0 sets without velocity boundary, Flag=1 sets with velocity boundary
Value: Velocity of vector in X,Y,Z directions (type: double)
Number of
pressure
boundary
elements
Tetra element
Element Type
Element ID Surface 1 Surface 2 Surface 3 Surface 4
Flag Flag Flag Flag
Surface 1 Surface 2 Surface 3 Surface 4
value value value value
Hexa element
Element Type
Element ID Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
Flag Flag Flag Flag Flag Flag
Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
value value value value value value

Repeated number of pressure boundary elements

Flag: Flag=0 sets without pressure boundary,

Value: Pressure (type: double)

Number of solid
elements

| Element Type

| Element ID |

Repeated number of solid elements

Flag=1 sets with pressure boundary

Number of scalar data blocks (number of scalars) *1

pd

~

Number of
temperature
boundary
elements
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Tetra element
Element Type

Element ID Surface 1 Surface 2 Surface 3 Surface 4
Flag Flag Flag Flag

Surface 1 Surface 2 Surface 3 Surface 4
value value value value

Hexa element

Element Type
Element ID Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
Flag Flag Flag Flag Flag Flag
Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
value value value value value value
Repeated number of pressure boundary elements
Flag: Flag=0 sets without temperature boundary, Flag=1 sets with temperature boundary
Value: Temperature (type: double)
Number of heat
flux boundary
elements
Tetra element
Element Type
Element ID Surface 1 Surface 2 Surface 3 Surface 4
Flag Flag Flag Flag
Surface 1 Surface 2 Surface 3 Surface 4
value value value value
Hexa element
Element Type
Element ID Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
Flag Flag Flag Flag Flag Flag
Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
value value value value value value

Repeated number of heat flux boundary elements

Flag: Flag=0 sets without heat flux boundary, Flag=1 sets with heat flux boundary
Value: Value that excludes heat flux at specific heat (type: double)

Number of heat
transfer boundary
elements

Tetra element
Element Type |

| Element ID | Surface 1 Surface 2 Surface 3 Surface 4
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| | Flag | Flag | Flag | Flag |
Surface 1 Surface 2 Surface 3 Surface 4
value value value value
Hexa element
| Element Type |
Element ID Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
Flag Flag Flag Flag Flag Flag
Surface 1 Surface 2 Surface 3 Surface 4 Surface 5 Surface 6
value value value value value value

Repeated number of heat transfer boundary elements

Flag: Flag=0 sets without heat transfer boundary,

Flag=1 sets with heat transfer boundary

Value: Value that excludes heat transfer coefficient at specific heat (type: double)

Number of heat
source elements

| Element Type |

| Element ID | Heat source |

Repeated number of heat source elements

pd

~

*1: The scalar data block is one block of the blue line portion. Repeats the number of scalar blocks to be calculated.

7.2.6 Result, Result#.

out

Result, Result#.out are common formats.

Total number of
time step step

Execution time

Analysis Type1 *1

Analysis Type2 *1

Element ID1

surface 1 of surface 2
element 1 element 1

Mass flow rate of | Mass flow rate of

Mass flow rate of

of surface 3 of

element 1

Mass flow rate of
surface 4 of
element 1

Mass flow rate of

surface 5 of

element 1

*2

Mass flow rate of
surface 6 of

element 1

*2

Prev Press Vx
Press

Vy Vz

e Temp

Scalar2

Scalar#

MuTau

Repeated number of elements on and after the second line

Prev Press: Pressure before step 1

Press: Pressure

Vx: X-direction velocity
Vy: Y-direction velocity
Vz: Z-direction velocity
k: Turbulent flow energy

e: Viscous dissipation rate

Temp: Temperature
Scalar2: Scalar 2

Scalar#: Scalar #

MuTau: Turbulent flow viscosity coefficient
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*1: Value identical to init.dat.
*2: Enter 0 when element shape is a four-sided body.




